I ordered an ICD2 but Sparksfun sent me an Olimex PIC MPLAB COMPATIBLE PROGRAMMER (PIC-MCP-USB Rev. F) instead!

Anyway, when I tried to make the build, I got this message:

Release build of project `D:\....\UAV Dev Board\MatrixPilot-2_0_2\MatrixPilot-2_0_2\MatrixPilot.mcp' started.
Language tool versions: pic30-as.exe v3.23, pic30-gcc.exe v3.23, pic30-ld.exe v3.23, pic30-ar.exe v3.23
Sat Feb 27 23:41:00 2010
----------------------------------------------------------------------
Tool doesn't support selected device.
----------------------------------------------------------------------
Release build of project `D:\_Business\UAV Dev Board\MatrixPilot-2_0_2\MatrixPilot-2_0_2\MatrixPilot.mcp' failed.
Language tool versions: pic30-as.exe v3.23, pic30-gcc.exe v3.23, pic30-ld.exe v3.23, pic30-ar.exe v3.23
Sat Feb 27 23:41:00 2010
----------------------------------------------------------------------
BUILD FAILED


Could you guys please help,

Thanks
Ryan

Views: 349

Reply to This

Replies to This Discussion

Please see attached photo of the board Sparksfun sent me - you think they'd send you the right one no?!
Attachments:
Probably the problem is not the board, but just some settings.

First check, if the proper device is selected as target.
Main menu: Configure / Select device / pic30f4011
Then check if there are no missing files in the source file structure.

regards,
Mine is not listed any longer at SF site. but it used be called MPlab 2 compatible with RS232 and USB port made by Olimux too and worked ok. sorry ,can't say whats wrong with yours. but some one else was adviced to send it back to SF. So pls check with SF also.
"Tool doesn't support selected device."

The "tool" referred in this message is the language tool, ie. pic30 compiler etc. Most probably the selected target PIC device is not the PIC30F4011 but a device from a different family.

I don't know your programmer board, but compiling is possible even without any programmer or debugger. In your case compiling failed.

regards,
Thanks, I'll try again.

Still not sure if that program will work though...it only recognized as PicKit Starter in MPLAB. I'll try again anyway.

Ryan
I've got it for "make" the file OK but couldn't program the board - the programmer Sparksfun sent me is not compatible. That's a shame.
Hi Ryan,

SparkFun no longer stocks an ICD2, so there is some confusion there when they get an order. I am not familiar with the programmer that they sent you, but I suggest that you send it back to SparkFun for a refund.

I am presently recommending either a PICkit2 or a PICkit3, which you can buy directly from Microchip.

I bought one of each, they both work just fine. But you will need to build your own cable to connect a PICkit to the UAV DevBoard. One way to do that is with a pair of 3 wire servo female-female cables, and some straight pin headers soldered back to back.

I am hoping that SparkFun will eventually stock the PICkits, and the cables.

Best regards,
Bill Premerlani
Ryan,

I just double checked...it is possible to connect a PICkit2 or a PICkit3 directly to a UAV DevBoard without a cable.

You just have to first disconnect the cable to PWM output channel #3.

Best regards,
Bill
Thanks Bill - I'll order a Pickit2 then.

Ryan

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service