I need a bit of help here, I am attempting to update the PPM encoder on my APM 2.5 following the instructions here in the Arduplane Manual.

I have downloaded and installed Flip 3.4.7.112 using all the default settings and have connected, shorted, and reset my board as per the instructions. When I attempt to connect to the ATMEGA 32U2 device via USB I get the following error messages:

I've tried a reboot and I have tried uninstalling the program, re-booting and re-installing but I keep getting the same error.

For the record I have tried both the download link in the instructions from the drop box (link is broken at this time) and I have downloaded it direct from the Atmel web site (same file). I am using a Windows 7 Professional 64-bit machine and have checked all my drivers and updates.

Anybody got any suggestions?

Nathaniel ~KD2DEY

Views: 4758

Reply to This

Replies to This Discussion

Hello,
This error message happens because you are using win 64 bits and flip has published a known bug on 64 bits. There is a workaround on the site of flip but i do not remember what that is.
Or alternatively upgrade from another PC which does not run a 64 bits version.

Cu
Hugues

OK for anyone who is interested I figured it out and was able to update the eeprom. What you need to do is update the device driver AFTER you boot the APM board and install the jumper and reset the Atmega32U2 (as per the instructions).

Right click on the ArduinoMega 2560 DFU and select 'Update Driver', browse to the location where your FLIP application is installed and find the 'USB' folder. For me that location was 'C:\Program Files (x86)\Atmel\Flip 3.4.7\usb'. Now click 'Next' and complete the update of the device driver. This may take a moment so be patient. Once it successfully competes follow the instructions for updating the PPM encoder here.

Once everything is working you should be able to connect via usb and see a screen like this:

Then after the update:

That's it no big deal! We might want to update the instructions for updating the PPM encoder to reflect this step updating the device driver.

Nathaniel ~KD2DEY

Hey Hugues,

Thanks for the reply. I saw that reference to an issue with 64-bit systems but I think that was fixed in version 3.4.2. The file we are using is compatible with the 64-bit OS but the device driver used for the Atmega32U2 needs to be manually updated via the device manager AFTER you reset the board and get it into DFU mode. Only then will the device show up in the device manager and be able to have the device driver updated.

Thanks for your input!

Regards,

Nathaniel ~KD2DEY

Hi,
Even I followed the same procedure, but in FLIP, my apm is not connecting to the software and also I checked in device manager but there is no other devices and also there is no "ArduinoMega 2560 DFU" option. I rechecked all the connections but I got the same problem. please help me to solve this problem.
Thanks.

I'm pretty sure this has to be in 32bit of windows. I can't get it to work in Win 7 64-bit. So I'm installing XP 32-bit in order to get the driver to work.

Pain in the butt.

I can't get it to work on 64-bit.

i got the same issue.

following the way that how to get  into DFU mode. device manager only print  "ArduinoMega 2560".

 there is no "ArduinoMega 2560 DFU"

I have two boards and both them get the same problem.

someone help, thanks.

I have the same problem with Windows 10 64bit...
But windows tells me that it has the best driver and will not let me replace it.
Anyone know how to fix Windows 10's drivers.

error message:

The folder you specified doesn't contain a compatible software driver for your 

device. If the folder contains a driver, make sure it is designed to work with

Windows for x64-based systems.

I've been dealing with this for days.. It all started when I tried to install new firmware via APM Planner 2.0.18 and it told me it couldn't contact the bootloader. Subsequent googling led me to forums with information similar to this one.

I've tried Ubuntu 14.04, Windows 10, OS X 10.11 and even a couple of virtual machines to get rid of "AtLibUsbDfu.dll not found." So far no luck.

In device manager all I get when I "reset" the ArduCopter (by connecting the two pins w needle nose pliers) is the sound of a usb device being disconnected and "Ports (COM & LPT) > USB Serial Device (COM3)" goes away. When I remove the pliers that same device shows up again, nothing changes with flip because I still hear that the dll is not found. It's troubling that I don't even see the ATMega device. Maybe my board is fried.. Any ideas?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service