Howdy,

So I've been unable to upload firmware to my pixhawk for a while now. I tried many things, but I always seem to return to this problem. When I attempt to make and upload my code from Eclipse it ends up detecting my pixhawk and says:
All done!
Skipping invalid documentation tag: 'default'
make[2]: Entering directory `/c/px4/Firmware/Build/px4fmu-v2_default.build'
Loaded firmware for 9,0, size: 879944 bytes, waiting for the bootloader...
If the board does not respond within 1-2 seconds, unplug and re-plug the USB connector.
attempting reboot on COM4...
if the board does not respond, unplug and re-plug the USB connector.
At which point it gets stuck there forever. Any clues on this? Prior to uploading the code, when my pixhawk is powered the main LED is a solid red which indicates a problem, but I do not know how to figure out the problem. I am currently waiting on my buzzer and I'll look at the boot log on the SD card shortly.
I am also able to connect to the pixhawk using the NSH CLI in Mission planner, but when I connect when all of the commands appear it jitters rapidly up and down, instead of having its original smooth auto scroll when outputting data. I don't know if this means anything.
Any ideas?
Thanks for the help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I've had no luck uploading new firmware lately using mission planner.
    I use apm planner 2 and works just fine to upload 3.2.1
    • Well, I'nm trying to upload my new code using the software eclipse. I tried uploading firmware using Mission planner before and I was able to select my firmware, but it could not connect to the MAVlink so it could not finish uploading.

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…