The PX4 USB driver on the Download page at Ardupilot is so old that it's for Windows NT and 2000 and won't work in Win7.  Is there an updated USB driver available?

Views: 3485

Reply to This

Replies to This Discussion

I'm not sure where your confusion is coming from but the USB driver on the downloads site is current, is the version loaded by Mission Planner, is the version loaded by APM planner, is the version loaded by Q Ground Control, and runs just fine on Windows 7.

I'm not confused, older versions of drivers won't work in Win7.  The USB driver is copyright 2000 and so old that it can't be installed. Neither Windows 7 or 8.1 can install a USB driver for the PX4 and this one won't work either.  You can try it yourself to verify that.  Also if you look at the file with a text editor you will see that it's for Win 2000 and NT copyright 2000!  I don't know why anyone would think that is current but there needs to be a more up to date one that will work.

Well I could be confused but I created the .inf file and several thousand people use it on Windows 7 and 8 every day.  

If you are interested in updating the .inf and the .cat files, please submit your changes as a pull request to

Contributions are always welcome.


It's not true that anyone uses the inf file in Win 7 or 8 since it's too old. You should try it yourself to see that it don't work, maybe you can borrow a PC from someone if you don't have one to try?

BTW, I missed the link to a second driver before called USB Driver for PX4 FMU & FLOW , do you think that one might be up to date enough to work or is it only for the Flow?

Nope!  Just checked and it's too old to use anymore too.

As a work around I dug out my old T40 with Windows XP and tried it on that.  The ancient USB driver does work in XP so it can connect now without giving a driver not found error. Mission Planner still doesn't work and can't connect to the PX4 but that's a whole other problem.

Steve, I have two Windows 7 machines sitting on my desk with this driver installed.

exactly, i meet the same problem in my window7, and try to connect the pixhawk with QGC, but there has nothing appeared in my screen, no any feature of progress show as the instruction demo video.

and i also browse lot of web post to try lots of methods, it is still failure to get the upgrade bar moving to next step.

some one know how to fix this problem, since the pixhawk is new from shopping.

Vorney, the reason you don't get anything on the screen with QGC is because they can't fix all the problems to make the program work so they keep screwing around with the user interface! Around the first of the year they did an update to the GUI that requires a higher resolution screen in order to see anything!  I had to switch to a better laptop just to get it to run again. It still won't work though and will never be able to make anything fly!  After 2 years it still can't even read the battery voltage from the PX4 so I gave up and put it all away. The PX4 and the software for it is nothing but RUBBISH!

How did you install QGroundControl and what version are you using? If you use the Stable or Daily build Windows installer it should automatically install the right drivers for you. Are you saying the driver did not install correctly for you?

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service