Hi All!

My Pixhawk is installed on Mariner quad (500). With the version 3.2 it has many nice flights, with very good ALT Hold control and AUTO flights.


After recent upgrade to 3.3.2, it changed its behavior: in Stabilize all is OK, stable and smooth control, hovers on 50% Throttle. When switch to Alt Hold, it starts rising up at full throttle! When switch back to Stabilize, all is OK with the control. Sometimes the rise up is hard to compensate with the trottle....
Looking at the logs, all seems OK, except the inconsistency in the IMU - accelerometers 1 and 2 shows different phase after switching to Alt Hold.

Do you have any explanation? Hardware fault or 3.3.2 software bug?

The last test flight log is enclosed.

Views: 2082

Attachments:

Reply to This

Replies to This Discussion

Thanks a lot Randy!

Indeed, the buzzer is close to the controller!

Will test without this!

Today i did several flights with both comtrollers, without the buzzer.

All was perfect! No any ALT issues, very stable hover at ALT _HOLD and POS_HOLD.

Seems all ALT_HOLD issues are of stupid buzzer, that signalling all the time when switching modes or some other issues. In 3.2 there was no any buzzer signals, in 3.3 every event is sounded.

Randy, can I suggest to have flag for the buzzer, to disable it after the ARM?

It is must for closed frames like Mariner - the body is watertight, hence high closed volume resonance. For safety reasons is good to have buzzer on pre-arm and arm, and for disarm information then.

Vesselin,

That would be a good idea.  We have a to-do item to add a MUTE parameter.  Potentially that to-do could be expanded in scope a bit to allow choosing when it should mute.

Hi Vesselin,

Is your issue solved by disabling IMU1 or IMU2, or just with moving the buzzer away from the Pixhawk?

I'm just asking because I've the same issue as yours.

Yes! After removing the buzzer away, all working perfectly!

No any issues with the baro, compass, etc.

It is same good result with the other Pixhawk clone.

Lucky that yours working perfectly.

Mine has same issue as yours had, but I don't have the buzzer on board.

I will try an auto tune, maybe it helps. 

You should reduce the vibrations to minimum - do you use damper plates?

It is the only way to use the Pixhawk. Here is photo of mine.

Normally I use tethered set with bungee for precise manual tune of the PIDs.

The procedure is well described here.

My set photos enclosed. I do separate Roll and Pitch tunes if non symmetrical frame.

Yaw is easy to fine tune on the strings also.

Attachments:

Of course I'm using damper. Almost same as yours, just made of carbon. Also motor holding plates are vibration damped.

My vibration results are quite good(I think), based on the wiki below:

http://planner.ardupilot.com/wiki/common-measuring-vibration/

With newer FW like v3.3 the values are bit different than earlier FW values, where +3/-3 and -15/-5 ranges were good values.

Pls see mine attached. Any advise maybe regarding my vibe results?

That bungee tuning bit funny ;) But I don't think I can mage it, my 750mm frame just too big to suspend the same way. I'd have to design something where I can perforfm the same tuning.

I use the same tune procedure for S900 - just tie the bungee to the copter body, and use two poles outside.

Do you have the 15.bin published to look on?

Not yet. But now I attach it here.

Would you pls take a look at? Maybe you see something  why copter woudn't hold its altitude.

Attachments:

The log looks good.

Do you have barometer air damping with dense polyurethane, as described there?

I had same with the S900, the air blow from propellers offsets the barometer, and the alt hold is dropping.

Thanks for checking log.

Is this barometer covering trick apply only for those Pixhawks which are based on top of the copter, oper air? Or for those too, which are under a plastic dome?Mine is covered with a dome. Anyway, should I add  the PU rubber? With what adhesive which doesn't the sensor and still let the air flow?

So, mine is look like this:


Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service