Solved by changing PC and USB port. 4 of 6 ports caused this error.

Mission Planner 1.2.53 (latest)

APM 2.5.2

OS: Windows XP

All drivers downloaded, installed and checked just before the test. APM moved to COM4.

After uploading different firmwares got this message: "upload succeeded but verify failed", each time with different byte addresses. Tried on two laptops with total of 6 usb ports. Only 2 ports continuosly upload without errors. Others fail.
 They fail only in MP upload. Mouse and generic Arduino uploads appear to be flawless.

I think this behavior must be noted in the manual so users will have in mind that they better have more than one computer on hand before working with Ardupilot.

Views: 901

Reply to This

Replies to This Discussion

Same thing just happened to me.  I haven't tried pushing it via Arduino yet, but I'll be glad to give it a shot.  Never heard of mouse... is that another programmer?  Briefly searching for it didn't reveal what I was hoping to find lol

this will be a usb power issue, or linked to the usb cable being used

I was hoping so, too, but I've tried three cables.

Here's an interesting bit: I was able to successfully compile and upload 2.73 from the APM mod of Arduino described on the wiki page.  Its link is in the pile of downloads here.

All of the settings I was fiddling with before I tried the Ard upload remained unchanged: 115200/8/1/none, single digit com port number, no other object connected to the APM during the load, laptop on AC power with USB power conservation disabled on all busses and ports.

No idea how half of this magic works, but I'm happy it did in the end.


when you upload, what sensors do you have plugged in? ie 3dr radio, gps, other

Mouse Driver. A man. Heard of him? Almost the same as Cattle Driver, but shabbier.

I've been uploading to 2 APM 2.52 boards with no equipment connected. So there's not likely to be a power issue.

There's also cannot be OS problem, because all 3 ports have the same driver, but 1 works and 2 not.

With my little mind I suggest that in checking procedure, in whatever part of the process, error correction is being turned off.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service