I recently purchased an APM2 and have been trying to upload the latest firmware to it. When I do, I get this error:

Upload succeeded but verify failed: exp C got 14 at 0

I've had the same problem using 3 different USB cables and on 2 different computers.  I've double checked that the USB baud rate is 115200.  I'm running Mission Planner 1.2.11mav 1.0 and trying to upload ArduCopter V2.7.3 Quad (I have the same problem loading any of the configurations).  I'm running on Windows 7 Home Premium.  The board has V2.4 silkscreened onto it.

I have a second APM2 which I can update without any problems using the same configuration.

Any idea how I can get this board updated properly?  Seems like a hardware problem to me.

I've posted this problem on the Mission Planner forum about a month ago and haven't had any responses so I thought I'd try here.  

I also sent e-mail to 3DR support twice (once a month ago and again yesterday) and haven't heard back.

Views: 8982

Reply to This

Replies to This Discussion

I managed to get it working through changing com port settings in de device settings to XON/XOFF or Hardware. Also make sure you have 115200, n,8,1 there..

Hi Bruce

Got the same error as you on my new APM2.5.  

Did try latest software og PM = no good (Upload succeeded, but verify failed: exp76 got 21 at 2)

Did try in CLI mode.... got this " NNNNNNNNNNNNNfN:$H@VxxxmaB;89///5Q! @ *@`5@E

"3 989000Z(@`st: %u
bytes free: Error: pure virtual call ?naninfovf.H?G!A??
````````?i3O!331!"2122h111113A3t3312223 u8:]K{~+!!!!! C!E!"s!! _!!;!-!!!! ! 7! +!!! !"m!"G! +!!! !" !! ! ! ! ! !! !!/! ?! ! ! ! !!! !!!!h"!S!!"!" !h""w!! !
!!!e!!!) %!#!!g!"c]E?$[O
Piz*8LQ.iz@PhrF#aXil}i-=M\{L., 1BS 5401 %&EU&QO>?9e==?


@>=o;>=o;L>u< @
#=>@{.>@{.>@L>,@?? @?=d @?=dL>L>@ @ @ @,
!{NTTg })'kk~?h



Init ArduCopter V2.9.1b

Free RAM: 2211
FW Ver: 120

load_all took 1040us
(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(  "

Did also try Arduino with the special APM25 version = no good. Got this "

avrdude: verification error, first mismatch at byte 0x0000
0x45 != 0x0c
avrdude: verification error; content mismatch " In every program uploaded code. Even small ones.

And i have now read alot of docs, and the sad answer is that the board is conclusively doomed.

I've only programmed it 8 times :(

Many people have the same error, and i think it's the building of board's architecture in some way.

I also have a Multiwii PRO and i have programmed it 100 times. And its still working.

But now my APM2.5 goes in the bin and so does my project :.(   unless i get my fingers in one of these USB programmers.

(in between the 8 times of programming, it flew perfectly with ALT HOLD aso)


Hmm is it possible to replace the Atmel Mega32u2 or is there any code in this chip (bootloader)

(i'm a ingeneer, so no big deal.)

Br Tvixen

The new chip is in my hand.... time to try it out.

Well it wasen't the 32u2 chip. Damn  I could replace the bootloader and it worked like a charm.

Went looking at the Mega2560 chip.

I tried to put a new bootloader of the Mega2560 through the ISP plug, but it comes with vérifications errors.

I can:

1. Get the signature

2. Get the fuses

3. Erase the chip

4. Write the bootloader code

But when i try to verify it, all the code is "0x00"  and it has 7158 Verification errors.

I think my Mega2560 is defective, and it's time to find something else to do :(

Br Tvixen

I had the same problem:

"upload succeeded but verify failed: exp 8c got DC at 102254".

As for me, the problem happened because I use Windows VM on MAC (VMware fusion hypervisor). It's very common issue when you use Serial port on a VM.

Try to use Windows box to upload the firmware. It helped me so potentially it may help you.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service