I recently purchased an APM2 and have been trying to upload the latest firmware to it. When I do, I get this error:

Upload succeeded but verify failed: exp C got 14 at 0

I've had the same problem using 3 different USB cables and on 2 different computers.  I've double checked that the USB baud rate is 115200.  I'm running Mission Planner 1.2.11mav 1.0 and trying to upload ArduCopter V2.7.3 Quad (I have the same problem loading any of the configurations).  I'm running on Windows 7 Home Premium.  The board has V2.4 silkscreened onto it.

I have a second APM2 which I can update without any problems using the same configuration.

Any idea how I can get this board updated properly?  Seems like a hardware problem to me.

I've posted this problem on the Mission Planner forum about a month ago and haven't had any responses so I thought I'd try here.  

I also sent e-mail to 3DR support twice (once a month ago and again yesterday) and haven't heard back.

Views: 8982

Reply to This

Replies to This Discussion

Have you tried with arduino?

when you load other firmware is it always the same error? ie "got 14 at 0"

also what do you have plugged into the apm. try and unplug everything apart from the usb.

No, I haven't.  I've got the Arduino IDE and would be happy to try that.  I'm not sure how to upload a built binary with the IDE - are there instructions on how to do that somewhere convenient?  Should I use these?  Also, where do the binaries for ArduCopter get stored?

Thanks for all the help, I appreciate it.

I've never plugged anything into the APM except a USB cable.  This has been happening straight out of the original packaging.

I just tried flashing ArduPlane V2.63 and got the exact same error.

OK, just did a successful Arduino build in Windows and have the same problem:

avrdude: stk500v2_recv(): checksum error

avrdude: stk500v2_recv(): checksum error

avrdude: verification error, first mismatch at byte 0x0000

    0x0c != 0x14

avrdude: verification error; content mismatch

I'm doing this on my Mac running Win7 in Parallels.  3DR Customer Service wanted me to try downloading via the Planner on a real Windows machine after replacing the USB drivers.  I haven't had access to a true Windows machine to try that yet.

Just for the heck of it, I tried building and downloading the simple Blink sketch.  I got the same error.

I tried this using both the Windows and Mac Arduino IDEs.

Thanks Bruce. one of two things then.

the bootloader is currupt, or

the atmega chip is damaged.

Can I replace the bootloader using USB or do I need a special programmer?  Any pointers on directions on how to do that?

I really appreciate the help.

Edit:  Found some instructions on how to use Flip.  Trying that now...

OK, just successfully replaced the firmware using Flip and I still get the same error trying to upload the new firmware.

I guess this means the atmega chip is damaged.  I'll send it back to 3DR.

there is another bootloader on the atmega 2560 chip. you need a avr spi programmer to upload that

I don't have an spi programmer, so I guess I'll just send it back to 3DR, hopefully they can try replacing the bootloader.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service