My USB connection broke off the APM board, is there any way around using the usb port?  Is it possibly to use the telemetry pins to connect to it?  I also have the the ground link of the 3dr telemetry can i connect that physically to the telemetry port?


Views: 4206

Reply to This

Replies to This Discussion

You can reduce the wear on the USB port by connecting a short micro USB cable, and then connecting a USB extension cable.

One Step ahead, but still not there.

  • Soldered some pins to UART0 pin-out and to RST.
  • Made a cable connecting my CP2012 USB UART to APM
  • GND - GND, +5V - +5V, TX - RX, RX - TX, DTR - RST
  • Board powers up
  • Mavlink does not connect
  • removed DTR - RST
  • Mavlink connects fine at 57600 and works well

So I was confident, that firmware upload will also work, but that's not the case.

After "reading hex" - "no connection".

I tried with DTR-RST connected, pushed the reset button at the beginning, middle and end of reading hex.

No luck.

Issue with the CP2012? Any suggestions?

Bootloader still runs at 115200..



I had an APM clone which didn't work right in the first place.

I'm on my third 3DR APM and haven't had any issues with the USB connection (APM2 x 2, APM2.5+)


setting COM6 to 115200 baud in Mission Planner won't let me connect to the APM anymore.

Does UART0 support 115200? Can I change the baud rate for the bootloader?

I never changed any baudrates on the APM. Where and how can I change these?


For MAVLink, use 57600.

For firmware upgrades, select 115200 and do not connect. You will have to push the reset button about the same time as you start upload.



It works!

For Mission Planner 1.2.38 you should use the following timing when uploading new firmware to APM 2.5

  1. goto firmware and select com port for usb to serial adapter
  2. select 115200 baud
  3. DO NOT connect
  4. click on desired firmware
  5. click yes to continue
  6. while detecting APM version press and release the reset button
  7. wait for download from internet
  8. after reading hex process started press and hold reset button until reading hex finished. Release reset button
  9. wait for the magic to happen

Thanks to all who supported me!


I have done all this but after updating the firmware apm is not connecting only green led is glowing and apm is heating too

please help me what to do ??

I have the same issue and got stuck at this stage. Have you managed to upload a new firmware?

Hi I have now followed the intructions above and it is working. I am using a HK mini apm connected ftdi via telemetry port! Thank you all! :-)

I also have a hk mini with a broken USB...  I successfuly got a hc-o6 bluetooth hooked up and connected the HKPilot  to my phone, but my pc doesent have a bluetooth interface yet.   I tried to make my own usb adapter cable but im not getting a connection... Does the usb to ftdi cable have extra circutry to make it work?  or will i be able to reflash through a bluetooth connection and don't need usb anymore? i have a USB ftdi converter that i use to program the blutooth modules if that will help me out

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service