I'm confused and a bit frustrated, would appreciate any help as I'm not sure how to proceed.

Setup: I have a pixhawk autopilot running Arduplane 2.77, using Mission Planner 1.2.95

I've been following this guide to get my CHDK enabled camera working with my pixhawk. I'm interested in getting the camera triggering based on distance traveled.

Obviously the guide was written with APM in mind, so it needs to be adapted a bit for pixhawk; specifically the setting for RELAY_PIN. I've kept the rest of the settings the same as in the tutorial.

Pixhawk has 6 AUX ports according to the quick start guide, I am assuming that the numbers above the pins correspond to the AUX port numbering. When you mouse over the RELAY_PIN parameter, it says that pin 54 corresponds to Pixhawk FMU AUX1.

Tried setting RELAY_PIN to 54, no joy. Did a bit more looking, discovered in the release notes for 2.77: 

"Improved relay code
The relay and servo set code has had a major overhaul, with up to 4 relays now supported for MAVLink control and much better support for the DO_SET_SERVO, DO_SET_RELAY, DO_REPEAT_SERVO and DO_REPEAT_RELAY MAVLink commands. Along with these changes is a new parameter BRD_PWM_COUNT which allows you to specify how many auxillary PWM outputs to enable, with the remaining outputs being available as digital relays. This allows you to re-assign some of the aux servo outputs on Pixhawk for use as relays, by setting the RELAY_PIN, RELAY_PIN2, RELAY_PIN3 and RELAY_PIN4 parameters. The pin numbers for these pins start at 50 for the first aux servo pin, and go to 55 on Pixhawk."

Additionally,I found this github issue about this same problem that states that the Pixhawk can't trigger CHDK because its relay pins operate at 3.3V instead of 5V.

So i suppose my specific questions are:

1) Is AUX1 pin 50 or 54?

2) Can anyone confirm that the relays, when working properly, won't be able to trigger CHDK?

Views: 67908

Reply to This

Replies to This Discussion

Waladi ..what settings do you have on MP ?  what time setting is the relay triggered for (try to shorten it) 4ms ?

Have you tried to isolate the camera voltage from the pixhawk using diodes on the camera plug end ?

Regards ..  

P.S my new cables will be compatible with Canon and Sony  Also 5v and 3v logic. all in one cable. 

Do you mind sharing the circuit of your new cable?

Hi Marco,

With Manual Focus setting on camera, the first 3 shoot was normal, but after that it's just hang.

When I test using Avometer, the Output cable from circuit is delivering 0.28 V without any trigger signal and delivering 0.45 V when signal triggered using MP or TX.

Below is how I connect the S2 cable to your circuit based on Thorsten diagram:

Hi Reuben,

Below is the setting on MP:

Tested with Duration: 2 / 3 / 4 / 10 / 30 with same result.

Will test with Diode today and report back.

I think the culprit is there will always voltage running even when the signal it not triggered. I hope diode will eliminate that voltage or will try to use small relay if I can source it.

Same with @Arga question above, do you mind to share the new diagram?

Thanks.

Hi Waladi 

Oh wow !! I just realized you are using the Circuit for Canon that requires 5v to trigger the camera..!!

No this is not for Sony !!!!!!!!!!!!!   Sony must use Neg (Ground) to touch Focus and Shutter NOT 5v !

In thoery i agree with @Reuben but in practice my camera it doesn't shoot with this two pin to ground.
A geotagged shoot made this week with my "FX-79" (real full res):



@Reuben:
Since Marco said that he was able to trigger the SONY A5000 camera using his circuit, then I was trying to use Marco's circuit to trigger the same Sony A5000 camera without success.

 

@Marco:
Are you connect the Shutter + Focus cable from Camera to output 5V as my diagram above?
and you are connecting Ground from Circuit to Ground from Camera, right?

Yes, and here work fine.

Woah! Reuben that circuit above isn't the same as you posted before here!! Perhaps that's why I couldn't get it to work. Hope this one does. Thanks for correcting.

@Reuben, please post info about your new "all in one" cable, thanks!

Hi For Canon use this one 

From my understanding on Sonys the Focus and shutter pins need to be grounded to fire the camera.. not fed 5v ?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service