I'm confused and a bit frustrated, would appreciate any help as I'm not sure how to proceed.

Setup: I have a pixhawk autopilot running Arduplane 2.77, using Mission Planner 1.2.95

I've been following this guide to get my CHDK enabled camera working with my pixhawk. I'm interested in getting the camera triggering based on distance traveled.

Obviously the guide was written with APM in mind, so it needs to be adapted a bit for pixhawk; specifically the setting for RELAY_PIN. I've kept the rest of the settings the same as in the tutorial.

Pixhawk has 6 AUX ports according to the quick start guide, I am assuming that the numbers above the pins correspond to the AUX port numbering. When you mouse over the RELAY_PIN parameter, it says that pin 54 corresponds to Pixhawk FMU AUX1.

Tried setting RELAY_PIN to 54, no joy. Did a bit more looking, discovered in the release notes for 2.77: 

"Improved relay code
The relay and servo set code has had a major overhaul, with up to 4 relays now supported for MAVLink control and much better support for the DO_SET_SERVO, DO_SET_RELAY, DO_REPEAT_SERVO and DO_REPEAT_RELAY MAVLink commands. Along with these changes is a new parameter BRD_PWM_COUNT which allows you to specify how many auxillary PWM outputs to enable, with the remaining outputs being available as digital relays. This allows you to re-assign some of the aux servo outputs on Pixhawk for use as relays, by setting the RELAY_PIN, RELAY_PIN2, RELAY_PIN3 and RELAY_PIN4 parameters. The pin numbers for these pins start at 50 for the first aux servo pin, and go to 55 on Pixhawk."

Additionally,I found this github issue about this same problem that states that the Pixhawk can't trigger CHDK because its relay pins operate at 3.3V instead of 5V.

So i suppose my specific questions are:

1) Is AUX1 pin 50 or 54?

2) Can anyone confirm that the relays, when working properly, won't be able to trigger CHDK?

Views: 67903

Reply to This

Replies to This Discussion

Plinio,

I don't think you will ever get great photos from the SX260HS on a quad. See my test results here: http://diydrones.com/forum/topics/lets-talk-canon-cameras?id=705844...

and comments here: http://diydrones.com/forum/topics/using-aux-pins-as-relays-for-chdk...

Right, but how did this circuit?
There's many variations in this thread.
Sorry about my question but... CHDK is installed correctly?? :-)

I asked Reuben about sending me one back on page twelve.

CHDK is configured correctly. I tried the cameras on my APM 2.6 with the same settings as the Pixhawk and it worked fine. I made the cable for the APM from the instructions on this thread:

http://diydrones.com/profiles/blogs/apm-to-chdk-camera-link-tutorial

I have an E-flight controller I will test to see if Reuben may have sent a defective cable.

Ok, have you the required 5V on the Pixhawk Aux port rail?
If you're just using the Power Module can not have it.
Some circuit, like mine, require 5V in the central pin of the rail for Canon camera with CHDK.

@Marco

Yes, I have a turnigy 5v bec attached to AUX 6. I'm also using the power module.

Does the Pixhawk have to be armed for this to work? The APM doesn't.

I presume you've reviewed the manual?

Yes.

I have no issues doing this with my APM 2.6 and CHDK.

Hi Bill 

Sorry to hear you are having problems 

I see by the photo you have the wires correct and i see you added a 5v supply .. Pixhawk setting is on relay ? Make sure the switch parameters are same as your switch on the tx i.e 900 - 1900 and duration is set for at least 10 ms ..

I am working on a better cable that I will send you once completed as tested, which be able to be used on either Sony or Canon just struggling to find the correct component at any of the big electronic wholesalers.  

P.s Has you have the wires now in the picture it will be too stiff and the pixhawk cannot "float" on the mounting you would be better off reducing the number of wires running to the Pixhawk .. I.E remove all the earth wires from the plugs and join them into one and then only have the one earth wire plugging in , also you can remove all the reds of the escs ( I presume the escs have no bec) ..this will help not to transmit vibes to the pixhawk.. I would also add a lead weight on the under side of the top white mounting ..to give the top side some weight to help damp out vibes..just my 2 cents :o)

Thanks Reuben, I appreciate your 2 cents.

Bill

Yep, Pixhawk setting is on relay.

CAM_TRIGG_TYPE = 1

Bill which are you running ardupilot or arducopter?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service