Voltage Drop on Pixhawk Power module under load

Voltage Drop on APM Power module

I have introduced some voltage/current issue into my quad but I cant track it down.
Here is the Breakdown of what I have:

1) 30a 4 in 1 ESC SKY III (Timing High)
2) MT4006 Motors
3) (2) 3s 5100 3dr Batteries
4) 14x5.5 CT props
5) 14 gauge wire
6) APM Power module
7) Auqacopters bullfrog frame

The weight all in is 2200 grams.

Here are my calculation from eCalc
http://ecalc.ch/xcoptercalc.php?ecalc&lang=en&cooling=excellent&rotornumber=4&config=flat&frame=550&tiltlimit=90&weight=2200&calc=auw&elevation=500&airtemp=25&qnh=1013&batteries=0&battcap=5100&battri=.0068&battv=3.7&battccont=20&battcmax=30&battweight=86&chargestate=6&s=3&p=2&esc=max_30a&motor=tiger_motor&type=46|mt4006-13&gear=1&propeller=t-motor_cf&diameter=14&pitch=5.5&blades=2&project=Bullfrog


The Quad will hover at 50% throttle but the voltage drops very rapidly. It drops to 10.3 in under 10 minutes triggering failsafe. I hooked a monitor up to the battery and spun the motors up to 50% (loaded ). Under load the power module shows 10.3 volts while the battery monitor still shows 11.5. I have swapped out the battery packs twice

I have tried to calibrate the power module via the instructions on the wiki. The voltage matches when with no load hovewever under load the power module voltage Drops off quickly.

a couple of other observations.

1) The current draw from the power module is higher that I would expect 27amp vs 20amps
2) The ESC is really heating up 160+ F, while the motors are at room temperature.
3) eCalc says I should 20 min of flight time. but the power module goes to failsafe after about 10 min.
4) Pluging my batter in right after the flight to the monitor reads 11.9.

I have read other similar threads about unexplained voltage loss but they do not seem to draw any conclusions. (http://ardupilot.com/forum/viewtopic.php?f=49&t=7265)

Should I take it for granted that the power module is bad. aka showing the incorrect voltage, or is there something else going on.

What does a normal voltage drop look like?


Thanks for any help or suggestions.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Yeah, I had this problem and I couldn't figure it out more than year by ordering many different power modules, but in result problem wasn't with power modules  but with my CHEAP EBAY PIXHAWK!!!

    Please don't buy any NoBrand pixhawk from ebay, aliexpress etc. 

    Once I bought Brand - "RadioLink" Pixhawk from Banggood I got 90-100% precise readings from any power modules.

    Here is link, but it's out of stock right now - http://www.banggood.com/Radiolink-Pixhawk-APM-Flight-Controller-Wit...

    It's much more expensive than cheap ebay copy, but much more cheaper than original. I was lucky, I got 35% clearance coupon, when I bought it.

    It was my last try buying new pixawk and it was worth that. I was really surprised when I saw precise readings with it.

    So answer is that simple, you get what you pay for, buy new pixhawk from trusted Brand or Buy original! :)

  • I'm seeing the same issue here. I've posted some info at rcgroups here: https://www.rcgroups.com/forums/showpost.php?p=37049653&postcou...

    Has anyone figured out what the problem is? I'm seeing a 2-3V discrepancy between what the PM is reporting and my multimeter reading under a 10A load.

    I've taken a video of it here: https://www.youtube.com/watch?v=SU3ClCOEYv0

    RC Groups - View Single Post - Pixhawk Power Module Accuracy
    RC Groups - the most active Radio Control model community: electric and fuel rc airplanes,rc helis,rc boats and rc cars. Features discussion forums,…
  • I am having a similar issue. I have an f450 that would pull around 20amps at hover with a gimbal/go pro and a 5amp 3s battery. I recently upgraded to the f550 frame and now with 6 motors, the gimbal/go pro, and 5amp 3s battery it pulls around 24amps at hover. The problem is that now the voltage is showing in mission planner below 10 volts and causes a failsafe. I hooked a voltage checker and the battery itself didn't get below 10.5. Any idea what could cause this? Is the voltage reported from the power module to the pixhawk directly? if so than the reported voltage should be almost equal to the voltage from the balance connector?

  • That Airbotpower board looks pretty cool and a nice all-in-one package. Very impressive design. I wonder if there are any US suppliers that carry it.

    I have not had the same problems with the Mauch sensor and my current readings are extremely stable and accurate. I normally use telemetry via the Android Tower App as well as FrSky Telemetry on my Taranis so I can't comment on real-time display in Mission Planner.

    Come to think of it I do have pretty regular "inconsistent compass" errors when powering up but that goes away if I rotate the craft around. I'm not sure if that started only after I installed the Mauch sensor or if that started earlier. On my S550 Hexacopter I moved the Pixhawk in between the top and bottom plate sandwiched with some Zeal gel so it's sitting only 1-2MM above the integrated power distribution board. My primary compass on the mast works perfectly though.

  • I not had a good experience with the Mauch Ubec and current sensor.

    The current reading that appears on Mission Planner is not stable , it varies a lot , much more than the standard 3DR current sensor making the current data unuseful .
    Mauch told me it was normal because it is a HAL sensor but I have another supply board with current sensor that is much more stable than the one from Mauch and it is a HAL current sensor.

    About the Mauch ubec , the basic version is a low cost D-Sun switching converter with a resistor instead of a trimmer .
    I had several headaches with my compass and also very strange behavior with a clone Pixhawk after I mounted  Mauch currrent sensor and Ubec .
    Mauch gave a great support but finally the problems remains .
    I do not want to damage his reputation , I'm just telling  my experience with his products , I might been unlucky or I  just did something wrong.

    I solved my problems installing Airbotpower, an high quality supply board with current sensor , it cost a lot more (about 80 Euro ) but I will not mount anything else on my next copters.
    Airbotpower board

  • thank you john

  • Yes I'm currently running the Mauch Power sensor and BEC on my Hexacopter and it works great!

    I'll be honest, the voltage drop is still there as soon as the load it applied (16.8V fully charged, drops to about 15.6-15.7 as soon as I throttle up) but then the voltage drop after that is extremely linear and I can use my batteries to their full capacity without hitting a low voltage alarm or low cell voltage, although I always land with about 25-35% capacity remaining.

    The other advantage is the voltage and current reading from the sensor are extremely accurate at all voltages/currents. It measures correctly starting as low as 0.5A which the regular power modules cannot do. I've tested the % remaining reported by my telemetry and compared that to what my charger says I put back into the pack and it's pretty much dead-on. I would highly recommend it.

    There are now two components instead of one to install. You'll need the BEC to power the sensor as well as the sensor itself.

    Also, I would recommend making sure you get the right sensor for you application. Now that I have an accurate measurement tool, I know that my Hexa draws 22-23Amps at hover, and a max of about 70-80Amps at a full punch-out (which I rarely do since this is an AP rig). However I ordered the 200A sensor which works perfectly, but comes with larger gauge wires that I had to route within my 550 frame and solder to an XT60 connector. The 100A sensor would have worked just fine and would have been easier to manage.

  • Link to power modules that are voltage accurate and current accurate? thanks! :D

    BEC ... is only a DC-DC step down (and maybe a filter)?

  • Power modules are still first generation.  They are not only inaccurate but are also inaccurate at different values throughout the spread of your battery voltage.  This means that even if you calibrate it at full power it will be inaccurate as soon as you throttle up at all.  This limitation is not severe and for most it is ok.

    Drain the battery to a voltage above your desired failsafe and calibrate it there.  The idea is that when it approaches that known voltage the accuracy will be at it greatest.  There are power modules that are not only voltage accurate but current accurate, the trade off is that they require a BEC and cost $21 currently.  (BEC is an additional 20)

    You are running a 3S system.  Your flight time is about correct.  Make sure they are charged up fully to 4.2V for a regular LiPo or 4.35 for the High Voltage LiPo's.  Higher voltage systems have longer flight times. 

    Do not depend on E-Calc ever again as it is not accurate enough.  Get your results just as you have, by building and testing the systems.  Remember your results. 

    Resting voltage will always be higher than what the battery does under load, it is a chemistry issue and is normal behavior.

    Your ESC heating up could be a number things, inlcuding: cheap ESC and/or components, inadequate airflow for cooling, the rating of the ESC is not as stated, bad solder connections, a failing ESC or a mismatch between the voltage rating of the ESC and the 3S battery.  In my experience, the lower the voltage the hotter they run but not always.

    A normal voltage drop will be nearly a linear downward line followed by a cliff at the very end, typically when a cell is around 3.3V. 

    Good luck bud!



  • John R said:

    Hi Eric,

    I know it's been awhile since this post, but I've just started experiencing the same issue with my Hexacopter. I think I've been having the problem all along, but I've just added a FrSky Voltage Sensor that give me real-time readings while in the air. I've calibrated the Pixhawk power meter but it would always read about 1-1.5V below what the FrSky sensor was reporting at the balance cable, so I just started going by Lowest Cell Voltage from the FrSky sensor...BIG MISTAKE!

    I was flying the other day and my Lowest Cell Voltage reported to my Taranis read 3.6V, so I assumed the voltage at the flight controller was about 10.8V (3.6V x 3s) which should have a little bit of flight time left, or at least enough to safely bring it back for a landing. Unfortunately, I looked up to see my copter slowly dropping out of the sky and crashing (fortunately a slow descent from only about 15 feet and almost no damage). My only conclusion is that the power module and/or power distribution board really are eating up more than 1V between the battery and the ESCs/Motors. Very frustrating!

    I've ordered a power module/BEC kit from Christian at http://www.mauch-electronic.com/ which I'm hoping will address some of the resistance and calibration accuracy issues.

    have you tried the new power module? Is it working? 

This reply was deleted.

Activity

DIY Robocars via Twitter
9 hours ago
DIY Robocars via Twitter
RT @NVIDIADRIVE: Season Beta has arrived! Check out the first race of the @roborace season, livestreaming from Anglesey Circuit Sept. 24-26…
16 hours ago
DIY Robocars via Twitter
RT @IndyAChallenge: Here is the ROS-based small-scale vehicle platform showing the ROS Visualization (Rviz) screen with multiple ROS nodes…
yesterday
DIY Robocars via Twitter
RT @IndyAChallenge: Here is Black & Gold Autonomous Racing's simulated racecar running a lap @IMS and showing the team's code overtaking ot…
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
RT @donkey_car: New Maintainers! Donkey Car 4.0 and more! Here is our September Newsletter! https://donkeycar.substack.com/p/september-donkey-newsletter?r=2ji2t&utm_campaign=post&utm_medium=web&utm_source=copy
yesterday
DIY Robocars via Twitter
RT @chr1sa: Kinda cool that we just hit 2,500 members of our Bay Area self-driving car racing league. More than 10k globally. Fast, cheap…
yesterday
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race is next Saturday. Compete from home using the @donkey_car simulator -- no physical ca…
Sunday
DIY Robocars via Twitter
RT @RoboticMasters: Students from @Sydney_Uni working hard on improvements and changes to @donkey_car simulator. @diyrobocars @adafruit…
Sunday
DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
Sep 23
DIY Robocars via Twitter
Sep 23
Derrick Davies liked lisa TDrones's profile
Sep 23
DIY Robocars via Twitter
Sep 21
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
More…