Here is my quad video:



Power board doesn't exists, just I soldered + wires together and - wires together.

APM 1.4 with latest ArduCopter code. Uploaded via Mission Planner.

Did leveling process successfully

Did radio setup process successfully

Did frame set to + mode

Before everything just erased eeprom using erase command on terminal

IMU Shield is attached as you may see in video

ESCs calibrated all at once successfully.

Propellers CW and CCW successfully attached and front, back, left, right attached to APM properly.


Frame is made from Balsa Wood.


ESC: DualSky ESC 25A

Motors: DualSky 980KV (XM2830CA-12)

Battery: 3000mah 11.1V 30C


Entire quad weight: 910 grams


What do you think now?

Views: 2255

Reply to This

Replies to This Discussion

I already sent them to this thread, please tell me what you think about mine.


What's wrong so? It's flat surface, no motion no vibration

They run for a little time, short period of time. Just 2 motors spins. All cables are OK. So what's problem here?

I re-calibrated radio again.

All cable connections including signals etc. is proper.

Recently I get sometimes (random) takeoffs, but after takeoff my quad always tries to go on some direction, like after random takeoff it tries to always go to left.

Cables are OK. But in motors test just 2 motors spin for short period of time and after some random takeoff, it always try to go on a direction.

I'm on mission planner, on Terminal tab clicking n Download Logs, and there are no logs..

I need to enable them before flying or something?

Or should i just try flying again and try downloading again ?

I went to the Troubleshooting on the wiki and went through all the tests, one of my motors on the motoros test was spining in the wrong direction.

I fixed the direction, and tried to takeoff again.. looks a little bit better but still flips...

Video after fixing direction:

In step 4. i didn't find the "hand test" that they are talking about.

Step 8. Did you setup and test your radio? Run test/radio to see. Pitch, Roll, Throttle and Yaw should all be 0 or near zero (60 or less). Move the pitch and roll stick to the lower right, you should see approximately 4500, 4500 in Channels 1 and 2.

i get:

IN 1: 0     2: 0    3: 500     4: 500   5: 500   6: 500    7: 500

And when i move the Pitch and Roll to lower right i get 1: -4500, 2: -4500

When i'm trying to run tests from CLI i get Sorry, Not 1280 compat.

After flying again still cant find logs...

Any ideas?

Everything double checked.

Still in motor test just 2 motors spins. Got some takeoffs, but I want it to take of more stable.

Any ideas?

Have you tried swapping the props around on that leaning side to see if it still wants to lean to that same side?


When doing the motor test i think the motors should spin 1 then 4 then 2 then 3. it should be in a clockwise direction around the frame with the long pause at the front (it doesnt always start at the front, but the pause will be)

looks to me like the back two motor signal wires are swapped around. they all look like they are spinning the right way.

Those ESC's look exactly like the Mystery 30A ones i am running (but with a different label). I had a problem with one of mine, a dry solder joint on one of the connections inside. ended up removing the heat shrink and re soldering all the legs and tabs of each transistor. 

when doing the motor test the motor on leg 3 would not spin, however the motor would spin up with the vibration of the other motors spinning, but was very intermittent. also there were some weird beeps every now and then.

Since repairing i have had no problems

Hey Chris,

I think they all go in the right direction, try playing the video on 720p Full Screen, you'll see arrows that i draw with a pencil, they mark the rotation and the front of the copter.

I can see your motors spin the right direction ie: turn the props in the correct direction to generate lift.

See in this motor test each motor is tested in a clockwise direction around the quad. yours has the back 2 motors in the wrong order. For a quad the front right should be first after the long pause, then the rear right, rear left then front left.

should be an easy fix, just swap the two signal wires on the APM.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service