Arducopter is limiting the total power output of my hexacopter to 37 amps when it has the potential for 66amps when at full throttle.

I bench tested many different motor and prop combinations to see which would be the most efficient for my arducopter hex 550.

I decided to use 6 x 1000kv motors with 9x4.7 props which deliver 710g of thrust at 11amps each at max throttle.

Why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.  (see mission planner tuning chart)

I understand that the controller needs reserve power for controlling stablization but 37 amps is only 56% of total power potential that could be used.

I have calibrated my escs many times thinking that was the problem but its not.

When i use my kk2 controller on the same hexacopter i get 52 amp draw at max throttle held down on the bench.

Is there a setting that i need to change to allow the controller to use more potential power.

I want to put more equipment on this craft but it needs more power.

Thanks in advance for your help.

the Chart below shows thrust output for each motor/ prop combination.

I decided to use a 1000kv motor with a 9x 4.7 prop. next chart

This chart is just the 1000 kv motor with 9x4.7 prop  

max thrust was 710 grams at 11amps

I went into the tuning page for Misson planner and see that at full throttle i am only drawing 37 amps for 6 motors.  Hexacopter held down at full throttle on the bench while connected to MP.  the hex draws about 25 amps at hover with no extra equipment on board.

why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.

I understand that the controller needs reserve power for controlling stablization but that is only 56% of total power potential that could be used.

Is there a setting that i need to change to allow the controller to use more potential power.

Views: 18719


Reply to This

Replies to This Discussion

Hello all ..

I seem to be having the same problem.. 
Has anyone else been seeing this problem with current code ?

I too am having this same problem.  From the ESC calibration mode, i get 33 amps at full throttle (tri copter).  Through the APM at full throttle, i only get 15-16 amps.  Roughly half.  What gives?

Well is there is a solution .. no one is talking about it.. I've posted a few question here on this forum as well but no replies..

For me.  rolling back to  2.73  worked.. (I did not measure amp draw)
But for me the copter would quit flying at 3.85 V per cell..

I flashed it manually( not using MP)  and now it will fly till the battery is dead  :-)

Only draw back is I'm not able to calibrate the ACC  ( MP version does not do anything on that screen)

I think the PID screen also give some error ( don't have my gear with me to check it again)

other than that if fly's fine right now :-) ..   but have not had time to test it further..

ODD there is not more people reporting the problem .. ( I got my APM form JDrones)   not sure if it matters..

I found what i think is a solution.  It seems as though APM wants the throttle pwm end points to be 1000pwm and 2000pwm for low and high respectively.  I went to the radio control calibration screen in MP and adjusted the travel on my throttle channel until the low and high were close to that.  Then i re-ran the radio calibration, disconnected, and did another test.  Now i get close to 27-28 amps at full throttle through the APM.  I'm happy with that, as i realize that it needs some headroom for stabilization.  

I did this as well..  but did not help the problem..

I don't have the same least I dont think so...  the copter would quit flying .. motors slow down ..  almost as if in fail safe..   when it hits  3.85V per Cell.. very odd..

Power prior to that seem like its fine.. ( even now with old code ) it fly's using same amount of throttle input..

I put all my channels so that match 1000-2000 as as close to as possible and re-calibrated..
the TX  .but still not help..

I really expected that to work also as it was off by quite a bit.. like  300 or so ect..

one odd thing.. there is some parameters for you to set min-max .. ( I expected that maybe those variables would be populated.. taking the reading from the calibration.. )

but it seem you have to enter in values yourself...

did not monkey with those variables as.. the EndPoints where now set to 1000-2000  and very close for the other channels..

There is a section for failsafe parameters and one of those paremeters is to go into failsafe when the battery is below a certain voltage.  Might want to double check that is disabled.  


did you upgrade form one version to another ?

My experience has been on new equipment.. ( new APM 2.5. and new copter) have not used  APM since hardware version 1.4  :-)

You can also test this by plugging in a battery that is below 3.85v, connecting to MP, arm the copter, and see if it goes into failsafe.  It might not let you arm if below the cutoff so another test would be to start out with a decent battery and run the motors until it cuts off.  Then see if it's reading failsafe.  Obviously, you either need to hold the copter down the whole time or secure it so it doesn't go crazy during this test...

Yeah ..  :-(  I check everything a few hundred times.. :-) .. all the failsafe stuff .. was disabled..

It drove me crazy .. haha..

yeah tried that .. there is not much I did not try..  with batteries.. fail safe.. ect..

I togged battery fail safe on and off thinking may it would reset or something..

I would use a fresh pack.. ( 3 new batteries) ..  like clock work .. it would stop at 3.85V..

No fail safe on OSD.. dont recall if I used the MP..but on OSD never showed FS or warnings.. .. after the battery gets low it.. would power on but.. power output was so low that.. it could not lift off the ground..

after the 2.7.3 Downgrade (   now I can fly it well past  3.85 when plenty of power)
on some old used and abused batteries..

One positive thing.. it made learn a lot about MP and all the parameters  haha..

I have a similar problem.  I've got a tricopter with 3 .10 size electric motors that can cruise at 50 amps.  Current use at WOT is only 22A with a fresh battery --using my 60 amp ESCs.  That's less than 50%.  I tried adjusting the transmitter range as well as fiddling with the MP Radio calibration range with no positive results.  One thing I did just for grins, I put my Turnigy 70A ESC on the same motor and unexpectedly it is pulling 30A, now .  I'm not sure I understand why the motors aren't spooling up properly and definitely not sure why the 70 A esc added 10A to the top end over the  60A ESC.  So if I go to a 90A esc is the motor going to pull 50A?  I was under the impression that the motor limited the current coming from the ESC.  I set the range on both ESCs per the mfg instructions.  Any suggestions are appreciated.

Try the older firmware   :-)  if you have time to play with it..  :-(

only problem I have with it so far is .. cant get MP to play nice..  but even with zero trim it flew rock solid on..  2.7.3 is what I used..

I heard similar from a friend he had some cheap no brand ESC.. and replaced them with T motor ESC's and all worked.. for him..   I'm using same T motor ESC and no luck..

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service