Why I cant arm my quad unless connected to mission planner

Hi,

Does the pixhawk have to be connected to mission planner for you to fly in loiter mode?

I appear to be unable to arm my copter when there's a fast flashing green light. I get a amber light come on briefly. HOwever everytime I connect it to mission planer it has been switched to land mode despite the switch on the radio is in loiter mode.

If I switch between the mode whilest connected to mission planner it's works as expected.

I have made sure the  failsafe for the station and battery are turned off then written them to the dataflash.

Any help will be greatly appreciated as this is confusing.

Views: 126

Replies are closed for this discussion.

Replies to This Discussion

Try apmplanner2 and post the .tlog it produces.

GCS failsafe is most likely to be the reason

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service