Wireless telemetry set up but not communicating with Configurator

I can use the X-CTU app to read the modem's parameters but when I open the configurator it just keeps trying to connect but never does. As long as it's trying to connect, the red light comes on the xbee plane side. What is the red light indicating? Also the orange lights on both flicker so it seems the are communicating but I can't get any activity in the configurator program. I've chosen COM5, 115200, and 30 second time out.

Is there some test I can run? I tried the ones on this page but didn't get any results. I tried using the serial monitor in Arduino 0021 but didn't get any response. Can I just put Serial3.print() and press send? I'm using carriage return in the popup and 115200.


Views: 797


Reply to This

Replies to This Discussion

Make sure TX/RX is wired correctly to the APM port. How is the airborne Xbee installed; some breakout board adapter ?  In my case I used a small chinese adapter, the UartSBee module and in that case pin designations would confuse since TXD pin output would refer to TX of an on board UART of that adapter that is not used. Same pin connects internally on that adapter to RX of the XBee. So in my case TXD of that adapter card edge connector goes to IMU telemetry OUT and RXD to IN which would seem odd at first. So in case you use a similar bee adapter module, then worth checking out.
I used the DIYdrones Xtreambee to do plug to my airborne side with xbee 2.4ghz. The

ASC/RSSI led light up when trying to connect. But the connection is always unsuccessful. I have check the connect fr the xbee to APM, no problem with connection of 4 pins.

Have you tried the Xbee loopback test (connect RX to TX on the plane side) within X-CTU? 
Does it work?

 Try setting he baud rate to 57600 (both on the XBees and in the code) and see if that works.

On the telemetry page (http://code.google.com/p/arducopter/wiki/Quad_TelemetryPage) there is a test program (at the bottom of the page) for testing the connection. Does that work?

Test code succesfull - i read port3 from computer but configurator still not connected...


Maybe the problem is with receiving data.

Try changing the test program like this;

// Serial3.println("Port 3");  <--uncomment this line and add the rest below it
if (Serial3.available()) 

int inByte = Serial3.read();    

That way, instead of just sending a lot of data, you only send back what you received and therefore also testing that you can receive data (which is just as important). 

i have found out my problem. It is the power supply from APM/IMU is not enough for my xtrembee adapter board.


If i disconnect the lipo and direct 5v from usb, my wireless got no issue with 1111000 baud.

But if i connect lipo with esc, then i have problem with wireless link.

messure the voltage which goes to xbee board

does the current following in the xbee adapter board cause the xbee to burn?


I am thinking of having a lipo regulator 5v / 4.8A to adapter board xbee.

the apm has a onboard power regulator...

what voltage is going to the xbee with lipo plugged in?

and what voltage with usb plugged in?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service