X UAV Talon parameters

HELP

I bought a XUAV Talon with wing extensions in 2015 and still haven't been able to fly it using waypoints and using the RTL. I am able to fly it manually.

The radio is set up with Manual, FBWA and RTL

Pixhawk with the latest Plane3.7 and Mission Planner

I have flown it manually and according to the MP, it will fly in a circle if the radio is turned off. Ground tested.

If I switch to FBWA it flies fine and stabilizes accordingly.

If I switch into RTL on the radio, it dives for the ground and the throttle increases.

Does anyone have the parameters for this as this has been most frustrating and I have been wanting to use the waypoints and fly it with confidence. My radio has been set up (T8FG) and it all seems to work with the plane, but for some reason, I cant fly waypoints and I am worried that if I lose signal, it will crash.

Look forward to some help.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I also have a Talon with extensions etc.  It has been a test platform, so I won't share my params as they have been all over the place, and is currently a high endurance 6S rig.

    You need to provide some more details: full system setup (autopilot, gps, telemetry, battery, motor, prop etc), and dataflash logs to start with.

    Shift the post over to discuss.ardupilot.org and I'll go through it with you.

  • if you are setting for the first time take someone' s help who has experience in setting pixhawk. you may be able to set for FBWA mode without much difficulty if you follow the arduplane.org/docs

  • Hi Martin

    WOW....?????!!!! I bought the plane and asked that it be set up to fly waypoints specifically. The guy (no name mentioned as he is a member and owns a shop) who initially set it up said that it was all set up to do that and all I had to do was switch into FBWA????? He claims he tested it as well and it worked with my RC. My problem is he is never easy to reach and he is about 500km away from me. I am new to all this and I am annoyed now. Thank goodness I have 30 years of flying but no experience in the Pixhawk setups, hence I have been able to test it in the air without a problem.....thank goodness

     I asked this "guy" who does work with his planes and he does surveying using drones etc and uses the Pixhawk, and you would have thought he could have told me this or set it up correctly. He has replies to many issues on the blogs. One questions his integrity then. 

    Tx very much Martin for informing me. I will try and set this up now.
     
    Martin Guttesen said:

    to fly waypoints you have to use AUTO mode 

  • to fly waypoints you have to use AUTO mode 

  • Tx Graham, I will be changing this parameter to see what happens on the next flight and will revert
     
    Graham Dyer said:

    A clue also might be that you said your TRIM_ARSPD_CM = 1600cm/s yet your plane is flying at 1100cm/s (11m/s) so that parameter is set at least 5m/s too fast.

  • Hi Martin

    Tx for your feedback. I will look at these parameters and see if it makes a difference.

    I haven't been able to test anything regarding waypoints yet as it hasn't worked after uploading the waypoints.

    When I add the waypoints, the MP says they are uploaded but when I fly and switch to FBWA nothing happens, and yet I can fly in FBWA and use the radio to control the flight.
     
    Martin Guttesen said:

    Mine works well with return to home
    the only thing i can see that you have different than i have is 

    param                 Mine yours
    VTAIL_OUTPUT    2      3
    RC2_REV              1     -1

    and i don't use the air speed sensor

    all the parameters of the airspeed are different
    have you tryed to plot gps speed against airspeed ? mine follows quit well


    try to disable the airspeed sensor and see how it goes

  • Hi Ravi

    Thanks for your reply, I do understand that one must not use someone else's parameters, but just wanted to compare.

    I will look at the pids.

    Much appreciated
     
    Ravi said:

    do not use someone else's param file. it may not work. jsut check for the PID for roll2srvo and picth2servo and NAV2prd from the wiki documents and create your own params for other items.

  • Moderator

    A clue also might be that you said your TRIM_ARSPD_CM = 1600cm/s yet your plane is flying at 1100cm/s (11m/s) so that parameter is set at least 5m/s too fast.

  • Mine works well with return to home
    the only thing i can see that you have different than i have is 

    param                 Mine yours
    VTAIL_OUTPUT    2      3
    RC2_REV              1     -1

    and i don't use the air speed sensor

    all the parameters of the airspeed are different
    have you tryed to plot gps speed against airspeed ? mine follows quit well


    try to disable the airspeed sensor and see how it goes

  • these are my parameters.

    Maybe someone can help me on this?

    Talon Paramters 20170101.param

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @_JonMyer: 🚨Attention DeepRacer's including #UndergroundDeepRacer🚨 Check our our LIVE stream that including @IAM_dbro Take a few moments…
14 hours ago
DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
Monday
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
Monday
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
Monday
DIY Robocars via Twitter
RT @chr1sa: The @DIYRobocars @donkey_car virtual AI car race is starting in 15 minutes! Watch it live on Twitch https://www.twitch.tv/mossmann3333 htt…
Saturday
DIY Robocars via Twitter
RT @chr1sa: Don't miss our monthly @DIYRobocars @donkey_car virtual AI car race tomorrow at 10:00am PT live on Twitch. Head-to-head racing…
Friday
DIY Robocars via Twitter
RT @sparkfun: Our completed tutorial on building an @NVIDIA Jetson Nano-powered @Sphero RVR gets your bot up and running via teleoperation…
Jul 30
DIY Robocars via Twitter
RT @SmallpixelCar: Freeway test https://t.co/4V5tV9lhIP
Jul 29
DIY Robocars via Twitter
Very small autonomous cars racing, thanks to an overhead camera: https://control.ee.ethz.ch/research/team-projects/autonomous-rc-car-racing.html
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
RT @chr1sa: Don't miss our virtual AI car race this Saturday! Real developers + virtual cars =🏎️🏎️🏎️ Head-to-head battles with thrills, sp…
Jul 28
DIY Robocars via Twitter
Jul 27
DIY Robocars via Twitter
RT @usashirou1: Jetson nano by Isaac Kaya #jetson https://t.co/Mu1N0CyQkN
Jul 23
DIY Robocars via Twitter
RT @GPUsolution: JetRacer mady by Iflytek company #JetsonNANO #Nvidia https://t.co/MimTymIwge
Jul 23
DIY Robocars via Twitter
RT @openmvcam: I love this: Mega or Mini? Image Classification on the 1MB OpenMV Cam H7 by Ish Ot Jr. in OpenMV, Edge Impulse, Internet of…
Jul 23
More…