Hello. I have problem with Xbee. I can change and save the flight modes formation during direct connection with APM 2.0 via USB port. But I couldn’t save the changes of flight modes with xbee connection. During Xbee connection, I change the flight modes formation via Firmware/APM Setup/Flight Modes then close the APM setup screen, then I re-open the flight mode, it is still the same formation before I changed. I will be glad if anyone helps me.

Another question is that I can’t calibrate the radio via Xbee Connection. After clicking the calibration, it says a saving problem on the channels.  

Note: For this works I have a healthy connection with APM via Xbee. Mission planner shows “connected” on the right-top corner. 

Views: 401

Reply to This

Replies to This Discussion

A quick guess would that you have only data coming from the APM. You don't have send. Are you using Arduplanee or copter?

Hi Bill. I appreciate your reply. This is an arduplane and I am using 900mHz Xbee for telemetry. This is a strange situation to describe. Let me explain what I did, firstly. Yesterday, I connected my APM 2.0 with my computer via USB cable and adjusted the flight modes and made the radio calibration without any problem. Then I unplugged the USB cable and connected APM via Xbee. The Flight Planner connected to APM without any problem. I opened the APM setup in order to check if I could do the adjustment via Xbee. But I couldn’t change the settings of flight modes and radio set up. It gave a failure message about saving. Today (after your massage) I reset the APM and reinstall the flight planner. Then I adjusted the flight modes via USB. I checked the APM with my radio and it was OK. After that I connected the APM via Xbee. At this time, greetings, I was able to change the settings via Xbee, but it wasn’t repeatable. It wasn’t repeatable because after the first change, for the second and further attempts, sometimes I could change and sometimes I couldn’t.

This is my first time to use the APM. I think, It doesn’t look like a big problem. I can figure it out by bring the USB cable of APM to the field and firstly do my changes with USB then connect it via Xbee. I didn’t try it but I am afraid that if I will need to change the data during flight via Xbee such as way point. I am not sure if I can or not. For initial flight experiments I will use USB cable for setups and calibrations. I will be glad if you share your opinions about the possible reasons. Do you think that I can change the way points during flight? 

It now sounds like an intermitant connection problem from the radio RX to the APM TX line. If its not fixed, possibly a broken cable, you will not be able to set Waypoints as you cannot send information to the APM Over The Air.

What adapter board are you using for your XBee to APM?

Hi, the Mission Planner is more timing critical with some things than it really should have been .. for XBee anyway. Or, your XBees occasionally lose a packet of data (not happening with a USB cable) and then MP complains,

With MP, doing configuration and mission planning with a cable connection is better.



Thanks for your all advices. As I understand, it is not a good idea sending WP with xbee, so I did my first experience by writing the WP with USB cable. It was a short flight but It was really good.

I appreciate your help. Best regards.



I made this: http://diydrones.com/forum/topics/mission-planner-toughened-for-hig...   . That should be able to send missions over a slow link also.

Ideally, you should also change one thing it the firmware on your plane/copter. It is described in hte link.



Hi Soren,

Thank you for your attention about my issue. I got your link and trying to understand. I want to ask another question, maybe related with your patch file. Since I am new for these things I don’t know the whole system but trying to understand. A few days ago I did some flying attempts with my arduplane. I tried to get data with xbee connection. I planned the way points and flew my airplane. After the flight I saw that the tlogs did not contain the all flight information.  Also during the flight the plane did not go to waypoints. It sometimes made turns, sometimes not but not to go the wright direction. Because of the tlogs were short, I couldn’t understand when the plane were flown by autopilot. I couldn’t even export the fly path into google earth correctly. I can’t understand why it was like that. I will be glad if you help me.

Best regards,


Reply to Discussion


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service