I find that I cannot connect to the PID screen using XBees. This used to work before.

However, I can see the Sensor/Radio-in/Motors-out screens using Xbee. GCS also connects fine.

When I try the PID config screen, it says something about an ID mismatch and "Port in use?".

So, to summarize:

I can't get the PID config screen to work with XBee.

Sensor output, Radio-in, GCS work fine using Xbee.


Everything works with USB.


Any pointers as to what I could be doing wrong?




p.s. since the Sensor view and radio view works, I assume the xbee config (port, speed) is OK.

I also tried reloading code and resetting EEPROM, but the problem persists.

Views: 896

Reply to This

Replies to This Discussion

Are you closing your sensor screen before trying the PID screen?

Yes. I closed the sensor screen and immediately after that I tried to open up the PID config screen. It says "mavlink connecting" and then I get a popup about ID mismatch and "port in use?" and a function list where the error occurred. I'll get a screenshot and upload.

Another strange thing -- after the error I do see the PID config screen with all the values as "loading". If I then click write -- it succeeds!

and are you running latest APM-MP?


I have seen this same error few times when jumping a bit too fast between windowses. But as you said, Sensor and radio output works find so it means that your xbee is ok so problem has to be on your computer.

Yes -- I did a "Check Update" before trying it out. Should I go out and get a fresh download from the code repository? I also rebooted the PC.

I'll try pausing between closing one window and opening the other.

Screenshot below:



hi there

i've got exactliy the same problem. Eror messgag just when entering pid in AC2 section.



I'm having general mavlink problems (ie. not connecting) and have tried everything over the last few days. in CLI test everything (gyro, accel, baro, compass, gps, etc) is responding with properly varying values, it boots up to fly mode properly and 'Ready to Fly', it has newest APMPlanner firmware and newest APMPlanner, and gets through the AC Setup in APMPlanner. It was working perfectly until I moved up a few versions of AC2. I have tried Arduino upload of the google code Downloads page zip of 2.0.23 and everything works but the mavlink. I cannot even get Mavlink if I install the APM HIL via the planner. I would question the hardware more if it didn't give me perfectly smooth readouts, show GPS 1.6 working, everything calibrates, etc.


I have tried the CLI reset / radio / esc under setup etc and have basically reinstalled firmware 20 times (from two computers) but no luck with triggering a Mavlink output. The configs on the Arduino build seem to have the GCS Protocol and Baud set correctly. I was thinking about GPS Firmware but I see the 1.6 and successful connection in the 'show' and 'gps' commands in CLI setup


Error after 30 secs is: "Comport open failed - Pease try again and make sure your not in CLI mode" which I am positive I'm not. But I can get into terminal and see the boot screen output fine. It seems to not be accepting incoming signals to start mavlink?


note: 2560 APM board

Neil, I just tried with an APM2560 board and the latest code and everything works fine for me over MAVLink, both via USB and Xbee. I've tried the sensor, PID and GCS screens in the Mission Planner over both USB and Xbee. No issues. So I'm stumped by your problem.


Anything unusual about your setup or settings? Can you try another PC?


I had changed my xbees to the recommended 900MHz. I went back to the old 2.4GHz XBees and everything works!

What threw me was that the 900MHz XBees sort of worked for sensor view, but didn't work for PID config.

Also, I think the problem may be that I can't get the 900MHz XBees to be XBP09-DP (as shown in the manual). The X-CTU utility insists that they are XBP09-DM. The back of the XBees say XBP09-DPSIT-156 revC and XBP09-DPWIT-156 RevC respectively.

I tried the procedure shown in the telemetry manual page. The step that says, "Now go back the Modem Configuration tab, read it and it should now say XBP09-DP" doesn't work for me.

I'd appreciate it if someone can provide more details on how to get X-CTU to download the correct firmware. Thanks.

Edit: I searched the forums here and see that other folks have encountered the same problem before. I'll also search the Digi support forums and report back.

Also, I think the problem may be that I can't get the 900MHz XBees to be XBP09-DP (as shown in the manual). The X-CTU utility insists that they are XBP09-DM. The back of the XBees say XBP09-DPSIT-156 revC and XBP09-DPWIT-156 RevC respectively.

I had the same problem getting the xBee 900 to be DP, but guess what, even though he x-ctu shows DM on testing, If I read the device on the programming tab, it showed DP!

That probably means you got them from Sparkfun, who messed up their firmware in the recent batches. The AC2 manual says how to fix this:


"Note: recent Xbee modules from Sparkfun may ship with different firmware and X-CTU may try to download new code, which will probably fail (cancel it). If your Xbee module is reporting that it's an XBP09-DM (rather than the correct XBP09-DP), do the following:

In the Modem Configuration tab select XBP09-DP from the drop-down menu and write it to the module. It will work for a while, then give you an error. Go to the first tab, select 9600baud and read it, which should work. Now go back the Modem Configuration tab, read it and it should now say XBP09-DP. Change the VID and baud rate to what you want (999 and 56k for me) and write it. Now it should work."

I've got everything working again. Here's the scoop.

[1] If you have the XBP09-DP modules, you must download XBP09-DP firmware. If you have downloaded XBP09-DM firmware, it will kind-of work, but will fail at the PID-config screen.

[2] X-CTU will report the module as XBP09-DM. Ignore that. Go to the Modem Configuration tab and do the following:

(a) Select Modem as XBP09-DP, Function Set XBEE-PRO 900, Version 1002. It is important that you select 1002. Version 1161 does not work at first.

(b) Click the Show Defaults button under the Parameter View.

(c) Click the Write button under "Modem Parameters and Firmware".

(d) Go back to PC Settings, change Baud to 9600. Click Query. It will show XBP09-DM. Ignore that.

(e) Go back to Modem Configuration. Click Read. It should show XBP09-DP as the modem. Version 1002.

(f) Now select Version 1161.

(g) Click "Show Defaults"

(h) Click on the DD parameter and set it to 0. This step is important, otherwise the 1161 firmware download will fail.

(i) Click "Write". Now your firmware is XBP09-DP Version 1161.

[3] Now change the baud rate and Modem VID, redownload and you should be good to go.


It will still show XBP09-DM in the PC Settings Query. Don't worry about that (Thanks Dani!).

All the information above was in the discussion thread on the telemetry manual page. 



Thanks. I'll update the manual to use these more complete instructions.

Reply to Discussion


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service