Hi all,


I have two XBee Pro 9's (XB09-DP in X-CTU) and have been unable to get X-CTU to read either one as the correct XB09-DP. What tipped me off to this problem originally is that when connecting my entire setup to the Ground Station software all I get is junk telemetry.


I am able to write the Modem VID and Baud Rate (use 999 and 57,600 per the manual and since I have a EM406 GPS) in XCTU. But when I click the "Test/Query" icon to make sure that the it wrote correctly it always states XB09-DM?


I believe that I am following the manual to the letter on how to correct this, but to no avail so far. I have also attempted what Chris Anderson instructed someone who was having what sounds like a very similar problem, seen at this link 


but this does not seem to work either. The process that I've been using is I manually select the XB09-DP from the drop down menu, write it, read it, select Modem VID and Baud Rate (999 and 57,600), and write it again. After all this I check the 'test/query' button and it's always still XB09-DM.


Any help is appreciated. After looking through the manuals and forums I am out of ideas so I could really use some help and suggestions. Thanks

Views: 1112

Reply to This

Replies to This Discussion

I have also been having the same issue trying to setup the XBees, they will only show up as XBP09-DM even after following the suggested steps.

Hope someone can help.


Hi Paul,


I was able to figure what I was doing wrong. But first are you able to get good telemetry? If you are then don't worry about the XBP09-DM thing. Also, let's make sure that you're using the exact same equipment as I am. If you're not then this may not help. For the aircraft side I am using the XBee Pro 900 White Wire Antenna (shown here: https://www.sparkfun.com/products/9097) with an Adafruit Adapter Board (shown here: http://www.adafruit.com/index.php?main_page=product_info&cPath=...). For the ground station side I am using the XBee Pro 900 RPSMA (shown here: https://www.sparkfun.com/products/9099) and the XBee Explorer USB adapter board (shown here: http://www.sparkfun.com/products/8687).


If you do have the same equipment and cannot get good telemetry here is what I found works. 


1) Go to Digi's website

2) Go to Support on homepage, on the dropdown menu that comes up click on Firmware updates

3) Under "Select a Keyword" drop down menu select XBee-PRO

4) Select XBee-Pro 900 Adapters and click "select this product"

5) Download the firmware zip file titled "82002673 A.zip"

6) Open up X-CTU, Go to "Modem Configurations Tab," Click "Download New Versions."

7) Select from "File" and browse to wherever you stored the zip file you just downloaded and load it in

8) Close X-CTU, plug in XBee Pro 900 White Wire Module w/ Adafruit Adapter using FTDI cable, Reopen X-CTU, select COM Port for your FTDI under PC Settings, the baud rate your XBee module was last set to (9600 if still on default settings), then Go to Modem Configuration

9) Select XBP09-DP for Modem, XBEE-Pro 900 for Function Set, 1061 for firmware, check always update firmware. Set your Modem VID and Baud Rate (999 and 38400 for me)

9A) NOTE: I have a Mediatek GPS Sensor, but it is this one: (http://store.diydrones.com/MediaTek_MT3329_GPS_10Hz_Adapter_Basic_p...) I'm not sure if this is the one that is referred to in the manual as EM406 because the baud rate for this sensor is 38400 and not the 57600 that is prescirbed for the EM406 in the manual. So if you do have the same GPS sensor as me, make sure to set it to 38400.

10) Click "Write" in X-CTU. If the reset prompt comes up click cancel. Go back to PC Settings and set Baud Rate to 9600. Now go back to Modem Config tab, set all of the same settings again, and click write.

11) It should write, when it's done it will come up as XBEE-Pro 900 - 232 Adapter. Do a read to make sure it worked. Ignore the "DM" that will come up in the test/query. To make it's working if the read worked look at "Serial Number High" and "Serial Number Low." These numbers should match those on the bottom of the XBee module modem. 

12) Now unplug this XBee, close X-CTU, plug in the XBee Pro 900 RPSMA module, reopen X-CTU, select COM Port and Baud rate, go over to Modem Config tab and perform a write using the same procedures as you did for the other one. Upon a successful write this module will read as "XBEE-PRO 900" only and NOT the 232 adapter. Again to make sure the write worked look at the serial numbers to make sure they match. 

13) You should be good to go.



Hope this helps. I know that X-CTU is supposed to download all new versions of Firmware automatically from the Web from it doesn't seem to do for the Firmware needed for these modules. Another issue was that this firmware update was issued in December and the last time the telemetry part of the manual was updated was November.


Let me know if you have any questions :)



Nice tutorial. Very clear and to the point.

I have one question. There have been complaints on the Sparkfun website concerning the capability of the Sparkfun Xbee Explorer USB adapter to power the Xbee 900 Pros. They tend to draw more current than the 3vdc regulator on the Explorer can provide causing the Xbee 900 Pro to go into reset. I use the Adafruit Xbee adapter with an FTDI cable on the PC end. The Adafruit Xbee has a 500ma 3vdc regulator and can handle the current requirements of the Pro.





That sounds like an interesting problem with he Sparkfun Explorer USB adapters. I personally have never experienced this problem and do not know anyone else who has either. I know this isn't much help - sorry. But my Sparkfun adapter seems to be working fine.


I do have a question for you though. I am attempting to plan a mission and am having some difficulty. What I have done is first I select and write waypoints to my ArduPilot Board using the Config Utility Software program. After this I open up the LabVIEW GCS program, turn on my ArduPilot system, and obtain telemetry communication and GPS lock.


But once Google Earth in the GCS loads to my town the waypoints that I programmed in using the Config tool do not show up. Also, in the Debug Data tab the message "MSG WP error 1" shows up over and over until the message "int home" shows up and stops the debug data. And after all this the waypoints still do not load into Google Earth.


If you have any idea what I can do to fix this please let me know. Any help is appreciated.


Well I tried to set up the XBees again using the steps you mentioned, but when I read the RPSMA module it still reads as an 232 adapter not the standard XBee-Pro 900. Tried again to read telemetry and only getting random text symbols

Hi Paul,

did you get any solution on this issue with the Xbees. I have the same problem trying to upload the function set "XBEE PRO 900". It gets loaded the function set "XBEE PRO 900 - 232 ADAPTER" when i try to write 1061 firmware. It happens with one Unit (White Wire), the RSPMA vers. loads the correct function set. I tried to load the international functionset, but had no luck.

I also loaded the 1002 firmware on booth with the correct functionset but but they are talking junk.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service