Hello i´m trying to configure this 2 modules of  900mhz xbee with this XCTU 32-bit ver. 5.2.7.5  but so far and even after try to read all the help available on the internet, it just dont comunicate one to another. So this is the problem i have :

1- I have conected both modules in the computer and they read the info for each bord;

2- One of them is on COM3 and the other on COM4;

3- Now in the tab "Modem Configuration" Set one modem as a Coordinator and the other as an End Device but i couldnt find that option; 

4- "Set PAN ID to any unique number used between the two modems" but i just dont find that option also!

5- Use the Serial Number of each device as the Destination of one another. (Both High and Low addresses). As you can see in the pictures i have only one "Destination adress"...... and not both HIGH and LOW  as i should.


So i will apreciat any help for this problems!!!

Views: 4018

Attachments:

Reply to This

Replies to This Discussion

Now in the tab "Modem Configuration" Set one modem as a Coordinator and the other as an End Device but i couldnt find that option

Use the Serial Number of each device as the Destination of one another. (Both High and Low addresses). As you can see in the pictures i have only one "Destination adress"...... and not both HIGH and LOW  as i should

Hi Luis,

Have you ever managed to sort your Xbee problem.

I am faced with the same situation as you.

Any ideas?


Cheers

Kevin

Hello Kevin,

so far i´m still with the problem, i just couldn´t make them talk to each other no matter what i do!

I have the same problem as you. I get the same information you get in the X-CTU application.

Don't know if you have tried this? Found this from another post, i just copied and pasted.

"

OK...I figured this out...disregard all that stuff I said earlier. I am not sure why it worked, it only would intermittently anyhow. I have figured out how to make it work consistently. 

Modules: Xbee 900 mhz XSC

Firmware version 1022

The DIY adapter boards 

The key thing to understand here is that the RF rate between these two modules is 9600 kbps. If your computer or the APM attempt to communicate with the XBEE module faster than that the buffer for the module will very quickly fill and you get an error. To make this a non issue you have to set the baud rates for the modules, the APM and Mission Planner to 9600. 

1. Connect to the APM via a USB cable as always in Mission Planner.

2. Select the Configuration Tab.

3. On the left side all your settings are shown. Scroll down to Serial3_Baud. Change that from 57 to 9. Write the changes.

4. In X-CTU connect to each XBEE module and make sure they communicate 9600 baud. They ship that way, so it shouldn't be too much of a problem unless you have been messing with the settings. You change this under the "Modem Configuration" Tab. Change "Interface Data Rate" to 9600. You can also set the "destination channel". Mine is 0100, I think it has to be in that format at least.

5. Attach the Xbee to the APM as described in the wiki.

6. With the APM powered up with an XBEE attached, you computer powered up with an XBEE attached, open Mission Planner, set baud to 9600 and connect.

It consistently works for me, not as fast as my 09P model, but seems fine. I have not flown with it, but it works great in my living room. I've read on some forums about the XSC model needing a little more power that the APM will give. I have no idea if this is true or not, I will fly tomorrow and see if I have any problems and report back. "

I tried XSC's a long time ago and they didn't work.  It was explained to me that the throughput is too small on the XSC for ardupilot.  I bought the Pro-900 and it's worked ever since.  

Hi Stephen,

I think these are max 9600, it's weird cause they are the Pro version, same function set and modem type as above.

I tried them at 9600 and Mission planner connects, just can't write anything to to board which is a pity, i thought that one would be able to increase the speed on these.


Was your the same as above pictures?

Cheers

Kevin

Hi guys

I have the same problem with xbee xsc(i cant write anything to apm).Can you guys please tell me what settings do you have under Xctu/modem configuration/Serial interfacing options/FL-software flow control and Xctu/modem configuration/Networking/TT-streaming limit?.

When i connect apm telemetry port straight to ftdi i can read/write but with xbee it seems to be only one way communication.

Also in streaming limit settings by default is FFFF(dec 6535?) witch i think it means only after 6535 bytes or a pause the xbee on the plane side can receive commands?

Thank you and please excuse my english.

Hi,

I have not managed to write to the APM, as you can see the BAUD rate is only 9600 which my understanding is to low to write to the APM.

I have connected them as per the notes above a posted from another user. It seems to work but very slow.

I have left my Pc side standard settings for hardware, the modems i couldn't change much or not sure if or what to change, i think i just did the destination channel and changed my Mission Planner and i could connect but as said, can't write.

So the conclusion is the the Xbee 900mhz, XBEE-Pro XSC 9600 is not going to work, you can monitor but not write. If i am wrong then please correct me.

I have bought 2 x Xbee Series 1 units to test, since i could not get my Series 2 Pro 2.4 units to work either.

Cheers

Kevin

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service