Xplane simulation does not work on newer firmwares

I can not get newer firmwares then 2.7 in hil mode to work with xplane. I can run a simulation fine using older firmware but not with newer firmware as i want to test out geofencing that is not in the older firmware.

With the newer firmware there is no control what so ever and if i go back to older firmware such as 2.7 it works fine

Views: 669

Reply to This

Replies to This Discussion

Yes, I get data on all areas, but just the initialising red light flashing still!

The red light flashes on mine up to the point where I press the "Sim Link Start" button, then the sim screen fills with data and the red light changes to solid with a blue light next to it coming on solid too.

Have you checked that you have the IP addresses in Advanced IP Settings in MP and on X-Planes correct.

Martin,  will try again, thank you. I think IP stuff OK - ..005 out 000 in etc.

I am using xplane 10. APM 2.6 MP 1.3.21 on the same PC. I tried yesterday all vintages of HIL firmware

I have added the info required to get the simulator work and get the following error message

I do not get any data in the simulator

I have never been able to calibrate the RC radio after uploading the HIL firmware so I reload a calibrated param file. RC calibration works fine in the normal flight firmware

Help please this is driving me nuts

@Maxwell--I see it's been about a month since your post.  I hope you found a resolution.  After a year-long hiatus, I'm getting back into my ArduPilot (2.0 in my case).  I'm a big fan of HIL simulation, but it always seems to have one issue or another.  I went ahead and updated MP and APM firmware and then went into HIL mode.  In addition to other issues, I eventually got the same error in your post above.  It didn't happen at first, then after clearing up it came back again.  One of the other issues I'm having seems to be getting the gains right.  At first, my transmitter inputs had no apparent effect on the virtual plane control surfaces.   I finally got a decent response to transmitter inputs going through to X-Plane, but when I tried auto mode things did not work out well (gains had to be set all the way down to 600 as opposed to the 10000 default settings).  In any case, in auto mode APM seems to be attempting to control the plane, but it would eventually crash.  While the issue seems related to gains, I think something more fundamental is wrong--I just can't seem to put my finger on it.

It's oddly reassuring to see that someone else is having issues.  If you were able to get things working, can you share the solution?


P.S.--I also have the issue of not being able to calibrate the transmitter.  The ability to do so comes and goes.  I have had this same issue in the past.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service