Hi

I have been having a somewhat inconsistent behaviour in the yaw control for my Pixhawk.  Having successfully installed a Pixhawk in my JR E6 heli and have had many successful spline flights.  On the E6 the nose always pointed to the next waypoint as I would have expected.  Since I had such great success I moved the Pixhawk into my large 800 heli.  After adjusting PID etc the heli flies very well in in all modes up to and including loiter.  WP_YAW_BEHAVIOUR is set to 3.  The behaviour seen is almost as if WP_YAW_BEHAVIOUR is set to 0.

The heli loiters really well including high wind conditions and will hold position for as long as the batteries will last.  The tail (yaw) is really locked in during loiter with wind at right angle to heli.  No toilet bowl effect has been seen.

Now in auto for the most part the heli will fly my auto mission with the nose pointed in one direction (i.e., the nose does not point to the next waypoint).  I say for the most part in that if I program an auto flight with a circle flight, it always does the circle perfectly.  It will yaw the heli so that the nose is always pointing to the centre of the circle.  It will go to the next waypoint with the nose pointing in the direction the heli was when it finished the circle.  So if the circle finished with the nose pointing north, the rest of the flight will be done with the nose pointing north.

I have had a couple of successful flights were the nose will yaw in the direction of the next waypoint.  But I have never had two successful flights one after the other.

Questions that I have are:

With an external GPS/compass module is the internal Pixhawk compass automatically disabled or ignored?  I ask as the new install has the Pixhawk located very close to the motor.

Is there a parameter that will let me disable the compass internal to the Pixhawk?  Is this what MAG_ENABLE is for?

Thanks in advance for any input.

Richard

Views: 907

Reply to This

Replies to This Discussion

I have had similar experiences with my Vario project.  In 3.2 I do not believe there is a way to disable the internal compass.  This caused issues with my setup because the Pixhawk was mounted too close to the engine and was causing the compass to drift, even with the external compass mounted half way down the tail boom.  I moved the Pixhawk to an isolated location behind the rotor mast and it is working well there.  I have heard that 3.3 will allow you to disable the internal compass.  MAG_ENABLE is strictly to enable or disable the compasses.  While using EKF, I have set my EKF_MAG_CAL to 2/Never and this seemed to help with compass issues as well.    

I have had the waypoint heading be off by 20 degrees consistently due to poor compass calibration, although the heading will always follow the waypoints.  Not sure whats going on there for your setup.  

Hi Chris, Solved my issue. It turned out to be the fact that the yaw control was not quite centred relative to what the radio calibration of the Pixhawk had as centre.  So during auto flight Pixhawk saw the yaw input and ignored the point yaw to next waypoint setting.  The model flew auto perfectly after setting the proper yaw neutral value.  The circle mode must take full control of all the channels ignoring all inputs including the offset yaw channel.

Thanks again for your input.

Richard

Ah, nice find, thanks for coming back to close the loop.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service