Yet Another Noob Who Can't Arm Their Motors

I have APM 2.5, Arducopter 2.9.1 and MP 1.2.38, a quadcopter kit.


I've been trying for 2 months to get my motors to arm. I perform the arming sequence as per the instructions (which I think might be outdated because they don't work), and nothing predicatable happens:

1- Without any power to the APM
2- transmitter is powered on and throttle increased to full
3- APM is powered on, ESCs beep once.
4- APM is disconnected from the battery
5- APM is repowered, beeps once
6- throttle on transmitter is lowered to zero, ESCs beep once.
7- motors respond to throttle correctly, so far so good...
8- throttle is at zero, yaw all the way to the right for 4 seconds
9- APM LEDs haven't changed their flashing sequence this whole time: solid blue, flashing red, rapidly flashing Tx/Rx.
10- APM is powered down, transmitter switched off. Transmitter repowered, APM repowered, but no motor response. Do I have to callibrate the ESCs every time I want to fly?


Seems like a simple problem brought about by contradictory and confounding documentation. Occasionally, the above procedure will yield no results (no motor response), but sometimes it WILL do something, yet other times the ESCs will beep twice with my throttle at full, then I'll drop the throttle to zero, the ESCs beep once, then the motors will respond to my transmitter! If it beeps twice, that means there's an error...? I cannot make heads or tails of it.


The LEDs are supposed to change flashing pattern durring the callibration, right? Arducopter's documentation has changed so many times, and I can't find the current version explaining what the flashing LEDs mean...


I'm at my wits end. PLEASE tell me what I'm doing wrong. 3DR customer service simply shrugs and throws more outdated documentation at me... Everything has gone so smoothly until now...

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Dear i am having the same problem red led continously blinking . i am trying to arm using throttle down and than bottom right but its not working red led wont solid.. ia m using turnigy transmitter APM 2.8 simonk 30A EsC BEC.plzz help me tell me that my transmitter pattern (throttle down and right) is correct or there is other patteren toa rm mottors /... i recently i calibrated my esc togather and it was working perfectly

  • Speaking of Pikhawk4, I just built a heavy lift drone with a 900'll frame,40amp Ready to Sky ESC's, 320kv motorsx4. The Esc's calibrate in Mission Planner and spin the motors. When I go to actually fly I get the green light on the Pixhawk. I pull both stocks in and nothing. I wasn't thinking and I pushed both stocks to the left and the motors fired off? Motors rev'd up to like 20% for like 4 seconds and then powered down the whole time I never touched the sticks after it started? Any ideas? One last question is there anyway to run power to the Pixhawk without using the power module v1.0 current sensor? Ice had 2 die in me. I have the wires soldered in the right placws, replaced the cables and I'm feeding the power in the right direction. I wanted To use my brand new DJI V2 Flight controller. However I can't get my laptop to fully communicate with the flight controller. P.o.s. Windows 10 has conflict because of the designers signature or lack of.
  • i saw that on another post i was reading about 5 seconds before you posted ./...thanks for the response chris...im trying to flood my memory with as many problems and fixes as possible so if i come across the same thing during my build..ill knoiw what to do

  • i thought for arming its supposed to be to the right for 4 seconds...disarm is left for 4 seconds....why is it reversed

    is it different for different firmware versions..

  • hey
    I'm having this issue too.

    Tx,Rx setup correctly.
    ESC calibration went alright.
    Could move throttle to control motor speeds.
    unplugged the battery
    plugged it back
    pushed rudd left/low throttle for 4 seconds
    tried increasing throttle.. nothing..
    pushed rudd right/low throttle for 4 sec. ..
    tried increasing throttle... nothing
    what now?

  • Righto! Human error is the cause of many screw ups. Thank you Mr. Anderson!

  • 3D Robotics

    Hi Dave, 

    I think you're referring to the ESC calibration, not the arming.  These are the instructions in the manual, which I've just tried again to confirm that they're accurate. (I'm not quite sure what outdated or changed documentation you're referring to; do you have a link?):

    Safety First! - Remove the props!

    1. Disconnect USB and battery. The entire system must not have power
    2. Turn your radio on and put the radio throttle stick at maximum.
    3. Connect the Lipo to power the APM, radio receiver and ESCs. You will probably hear one or two short musical tone from the ESCs.
    4. When the APM boots, the Red-Blue LEDs will cycle slowly and continuously
    5. Leaving the throttle stick at full, disconnect the Lipo and reconnect it again to reboot the APM and power the system. The APM will now pass the radio signal directly to the ESCs, triggering calibration. The Red-Blue LEDs will cycle quickly - You will probably hear the short musical note and then 2 beeps (it depends on what brand of ESC you have; the 3DR ones will do as described). After the two beeps there is a pause, during this pause drop the throttle to full down. You should hear confirmation/arming beeps. Move quickly to the next step.
    6. Do not unplug, move the throttle up a little to confirm all ESCs are armed and the motors are working in sync.
    7. Unplug the battery again and then reconnect. Now arm the APM with right rudder/low throttle for 4 secs, release rudder and then all your motors should spin if given a little throttle.
    8. Your ESC's are now calibrated. No further action is required.

    If that's not working for you, I think there are two possible explanations:

    1) Your throttle is reversed on your transmitter

    2) Due to a failed attempt, your APM is stuck in calibration mode. You need to reset/erase the board. Go into the CLI and enter Setup/Erase, then Setup/Reset. Then go through the Mission Planner configuration process again. Make sure that the green bar for the throttle channel goes up when you push your throttle stick up (if it doesn't, reverse that channel at your RC transmitter) 

    Please let me know if that sorts it out.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…