I have APM 2.5, Arducopter 2.9.1 and MP 1.2.38, a quadcopter kit.

I've been trying for 2 months to get my motors to arm. I perform the arming sequence as per the instructions (which I think might be outdated because they don't work), and nothing predicatable happens:

1- Without any power to the APM
2- transmitter is powered on and throttle increased to full
3- APM is powered on, ESCs beep once.
4- APM is disconnected from the battery
5- APM is repowered, beeps once
6- throttle on transmitter is lowered to zero, ESCs beep once.
7- motors respond to throttle correctly, so far so good...
8- throttle is at zero, yaw all the way to the right for 4 seconds
9- APM LEDs haven't changed their flashing sequence this whole time: solid blue, flashing red, rapidly flashing Tx/Rx.
10- APM is powered down, transmitter switched off. Transmitter repowered, APM repowered, but no motor response. Do I have to callibrate the ESCs every time I want to fly?

Seems like a simple problem brought about by contradictory and confounding documentation. Occasionally, the above procedure will yield no results (no motor response), but sometimes it WILL do something, yet other times the ESCs will beep twice with my throttle at full, then I'll drop the throttle to zero, the ESCs beep once, then the motors will respond to my transmitter! If it beeps twice, that means there's an error...? I cannot make heads or tails of it.

The LEDs are supposed to change flashing pattern durring the callibration, right? Arducopter's documentation has changed so many times, and I can't find the current version explaining what the flashing LEDs mean...

I'm at my wits end. PLEASE tell me what I'm doing wrong. 3DR customer service simply shrugs and throws more outdated documentation at me... Everything has gone so smoothly until now...

Views: 16076

Reply to This

Replies to This Discussion

Hi Dave, 

I think you're referring to the ESC calibration, not the arming.  These are the instructions in the manual, which I've just tried again to confirm that they're accurate. (I'm not quite sure what outdated or changed documentation you're referring to; do you have a link?):

Safety First! - Remove the props!

  1. Disconnect USB and battery. The entire system must not have power
  2. Turn your radio on and put the radio throttle stick at maximum.
  3. Connect the Lipo to power the APM, radio receiver and ESCs. You will probably hear one or two short musical tone from the ESCs.
  4. When the APM boots, the Red-Blue LEDs will cycle slowly and continuously
  5. Leaving the throttle stick at full, disconnect the Lipo and reconnect it again to reboot the APM and power the system. The APM will now pass the radio signal directly to the ESCs, triggering calibration. The Red-Blue LEDs will cycle quickly - You will probably hear the short musical note and then 2 beeps (it depends on what brand of ESC you have; the 3DR ones will do as described). After the two beeps there is a pause, during this pause drop the throttle to full down. You should hear confirmation/arming beeps. Move quickly to the next step.
  6. Do not unplug, move the throttle up a little to confirm all ESCs are armed and the motors are working in sync.
  7. Unplug the battery again and then reconnect. Now arm the APM with right rudder/low throttle for 4 secs, release rudder and then all your motors should spin if given a little throttle.
  8. Your ESC's are now calibrated. No further action is required.

If that's not working for you, I think there are two possible explanations:

1) Your throttle is reversed on your transmitter

2) Due to a failed attempt, your APM is stuck in calibration mode. You need to reset/erase the board. Go into the CLI and enter Setup/Erase, then Setup/Reset. Then go through the Mission Planner configuration process again. Make sure that the green bar for the throttle channel goes up when you push your throttle stick up (if it doesn't, reverse that channel at your RC transmitter) 

Please let me know if that sorts it out.

Hi Chris,

Arming the motors is indeed the issue. Everything you've detailed from disconnecting the USB and battery works swell, up to the part where I unplug the battery, reconnect the battery and hold right rudder/low throttle for 4 seconds, when nothing happens.

I purchased the kit from 3DR, so I suppose the ESCs are 3DR, therefore I have to calibrate them manually? But the steps to automatically calibrate them work up to the final step (arming the motors).

I've checked my connections, checked my Rx/TX throttle, erased the APM, sacrificed 5 goats to Shiva, changed batteries on the Tx, and still no dice.

The outdated info I mentioned is in a 4-page PDF a was linked to by CS, but I cannot find the original email with the link. There isn't a date for the document, but it only talks about APM2, not 2.5, so that might be some indication as to which doc I'm referring to.

And just to clarify: "setting the endpoints" is a term interchangeable with "calibration", correct?

I have the 3DR kit also.
My motors arm when I hold it to the left. Try that.


Thanks Randy, but no effect.

How do I know if the motors are armed? Do I turn the TX and/or the quadcopter off and on to see if the quad "remembers"? Is this something I need to do every time I fly?

Also, I tried going into Tx programming mode, then exited it just to make sure that programming mode was disabled. It had no effect, but it was something to make sure of.

Randy: did you have to calibrate the ESCs manually?

I calibrated my ESCs both manually and in auto.
Try this, with the props off.
Connect to mission planner.
Plug in the battery.
Mission planner should say something like disarmed.
Hold to the right or left in my case four seconds. Once armed then the message on mission planner will go away.
Trying adding throttle and the motors will spin.

Thanks Randy, but...

The motors arm and react to my throttle (the red and blue LEDs blink rapidly then red stays on solid, the MP says "ARMED), but if I don't keep the motors whirring at least 10%, the motors will disarm themselves 30 seconds later (red flashes). Is that a safety feature?

I can rearm them again by holding left yaw for 5 seconds, but afraid this might happen in flight... 

How does one arm the motors permanently? 

Hi Dave,


I suggest to try the following:  reverse the yaw on the Tx and do the Tx calibration again(make sure the bars move in the correct direction!), then follow the advice of Chris Anderson.

I have to hold right yaw/no throttle for more than 4 seconds and if the motors aren't turning, they disarm.



What is your firmware? 2.9.1?
I'm using 2.8.1 and haven't had that problem but I'm thinking it may be a feature in 2.9.1. I'm going to install 2.9.1 shortly.
I assume you have done the radio calibration?
What TX are you using? I have DX8.
Have you setup the fail safe on low PWM?
Sounds like everything is working. Lights on the APM are correct.
Perhaps you are ready for a mini test flight.


It works!

The drone arms the motors when I hold left yaw in the Tx... It seems the ESCs have been calibrated this whole time, just that I was holding right yaw! The mysterious LEDs are behaving consistently (still mysterious though). I remember seeing something about 'left yaw' to arm the motors in the wiki, but no matter- it works!

I have firmware 2.9.1. I've calibrated the Tx (a DX8). I have yet to set the low PWM failsafes, thanks for reminding me. 

Now for that mini test flight... Thanks everyone!

Dave, it *is* supposed to be right yaw. The fact that you have to push your stick to the left means that your rudder channel is reversed. Please reverse it at the RC transmitter side. 

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service