Not sure if I have an odd setup here or just something intended for an older version apm.

Win 7 could not find drivers. Tried to install manually but drivers not recognised.
Inspection revealed interface chip is silabs cp2102 (USB to UART Bridge)
Found drivers on silab site which work with mission planner.

Does anyone know if this should work with andropilot?

I tried it unsuccessfully with an old otg cable that was lying around but the cable may be faulty. Waiting for new cable to arrive...


Views: 6559

Replies to This Discussion

Hi Ed

Here's where I got the correct driver for my Windows based machine.

However I did not need to instal any drivers for my android [ 7" Extreme 7C }. I did however have an issue with it connecting. It did not see the usb / otg cable connected. I thought I must have a bad cable. The problem wasn't the cable it was the android wasn't in 'usb host' mode. That's what lets the droid see things connected to the usb. I found a neat little app called 'USB Host Check'. I got it here

however google play probably has it as well. Anyway after I installed this I was able to tap 'Fix' and it then put the droid device into 'host mode' and then it worked great!  Good luck!!

Why are you guys buying knock off radios? Spend a few extra dollars and buy the original design you couldn't give me a set to use for free. 

Hi Richard,

Many thanks for your interest but unfortunately the drivers you mention did not work for me. Seems my radio uses a different chip as interface between radio and usb plug. usb host check did not work for me either, at least no change anyway.

Another app (usb host) controller did on the other hand report correctly some details of my connected 3dr radio lookalike. i.e. "silicon labs CP2102 USB to UART Bridge Controller". Since the only way the android app could have got this information is via the usb connection I have to assume the data link is working but andropilot reports no link and continues "looking for radio"?

Also I tried connecting a usb keyboard and that worked too, so I think the cable is OK. Incidentally I've tried both my galaxy s2 phone and nexus 7 tablet both of which I believe are known to work with andropilot. 

It's not just the money John, I'm having loads of fun buying stuff from banggood and most of the time being pleasantly surprised. For example a £17.00 gps which came in the same package as the 3dr radio worked right out of the box. And after all the 3dr radio is working in mission planner so can't be that bad. All this stuff is going into my first scratch build which looks and feels very heath robinson so no big deal when it crashes.. LOL.

That's to bad I would not have guessed that. Sure seems like if it worked with mission planner on a pc it would also work on a droid running andropilot! Did you see this page that has a driver just for droids?  Then again I didn't need it and I'm guessing most others did not as well or it would be mentioned a lot. Do you have the debug setting turned on in the settings on your droid? Also I think there is another setting regarding is it okay to run 3rd party apps? Select yes. I doubt it's either of those things but kinda clutching at straws now. Sure seems like it's just some simple little thing being as it works on a PC. 

I remember when I used usb host check then' fix'  it suggested I needed to re-boot the droid.. I think... 

Thanks for the suggestions Richard.

I only just learned you can connect andropilot direct to apm (or in my case crius aiop V2).

When I try this andropilot acknowledges a telemetry link but then just says "looking for vehicle".  No data or parameters are showing up?

I'm starting to suspect the otg cable again... New one should arrive early next week...

I don't know why it didn't occur to me before but I just tried connecting to droidplanner and it just worked no problem. So I guess there is some incompatibility to do with the interface that droidplanner handles but andropilot doesn't?

That is odd!! 

Two things I have found out about from You Tube is to make sure you have the correct Baud rate set before you connect, 57600,  and are the TX and RX wires the right way around on the lead from radio to APM... TX on one goes to RX on the other end and RX to TX.

Check these.


you cant connect mavlink if you have PC to APM USB connected.

I dont suppose anybody knows the USB wiring for the radio in the picture. I'm trying to make a female lead for it to plug into to commect to a bluetooth bridge,

Theres 4 pins.. When I plug it into the computer the outer left reads 4.8v  the next one reads 1.8, second from right read 4.8 and the case reads 4.8   Postitive on the right.



© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service