I'm using Andropilot to control different platforms:

- Arducopter on APM

- Arducopter 32 on VRBRAIN

- MegaPirateNG on CRIUS AIO Pro

Ardupilot works great on all the platforms but Follow Me / Lead It functions seems to have problems with version 3.x 

On all the platform Follow Me was working perfectly on version 2.9 but with new version 3.x Follow Me is not working anymore: as soon as you activate follow me copter goes crazy and you need to switch back to manual control.

I've experienced the same problem on rel. 3.x on APM, VRBRAIN and today with MPNG 3.0.1R2...so the problem seem related to Ardupilot controlling Arducopter 3.x   

Is anybody experiencing the same problem?

Luciano

Views: 3934

Replies to This Discussion

Interesting - yes, if someone else has copter and could confirm this new breakage with 3.x that would be great...

I've experienced this a few times. Upon activation, Guided/Followme cause the copter to freak out and fall. It has also worked fine. Very aggressive compared to 2.9(both with stock PID). Admittedly, I haven't done much Guided testing on 3.0.1, I've been working on tuning for a while. My copter has been stripped for parts temporarily, so I can't test it out right now. Also why I didn't partake in the 1.7.07 Beta. Sorry Kevin, next time. I'm attempting to build a rover. Hoping to have them both running by the end of the month.

did this issue get resolved? it happened to  me as well but i thought becuase i was in guided mode, i have video of it http://youtu.be/lu-9TPxRj90?t=2m51s incase some one needs to see it

I am running 3.0.1 on my HexTreme hexacopter and have tried Followme using a Android tablet several times with Droid Planner. Every time I activate Followme the copter shutters, then starts climbing, then hesitates, shutters and climbs some more. This continues until I take it out of Followme witch require multiple attempts of touching the Followme option on the tablet and switching the R/C transmitter from Loiter to Stabilize and back. the first few times it says it is in loiter but then automatically switches to guided mode. After the third or fourth attempt I can get control back. I have repeated this same sequence 4 times with the same results each time. All other functions including single and multiple waypoints work perfectly. It is very stable in Loiter.

there is a Distinct difference between Follow Me on Andropilot and Follow me on Droid planner. I also hit Follow me on Droid Planner and the Quad immediately shot up into the Air about 30-40 feet, then just sat in Alt Hold/Guided mode. I also couldnt get the radio to override the Guided mode on a tablet, I would hit RTL, but Droid Planner would switch  back to guided, i also tried to uncheck follow me, but it wouldnt release it. i finally had to crash land the craft to get it down. Andropilot seems to have implemented this in a better fashion if that helps

Haven't tried FOLLOW ME with DroidPlanner. I've flown FOLLOW ME using Andropilot a lot of times but I've never had this kind of problems. 

Just checking in on this old thread.  I presume follow me is still working fine for folks with the latest  AC?  I tried it recently with 3.1 and it seemed okay.

i am actually gonna try it out again this weekend weather permitting in florida :) last time it didnt go well, see video above

Hmm - were you using droidplanner or andropilot?

that was andropilot. but i will test again, i didnt have Droid Planner at the time. when i did try droid planner, the Aircraft shot up into the sky what seems like 20-30 meters a few weeks later, i'll let you knwo how it goes tho and i appreciate you following up on this. thanks. i will be recording the use of guided and follow me

we've got a good day here in florida, i'll be testing out follow me and guided modes on a nexus 7 with a small APM 2.6 quad, will upload video later tonight

Tried a month ago with APM2.6 and 3.0.something - it failed the way Luciano describes: the copter gone crazy and fell down.
Tried today with Pixhawk and 3.1 - the same behaviour.

Either my smartphone (Samsung Galaxy Note) sends crazy GPS data, or something doesn't work in the code.
Luciano, TheMightyTor, any new tests/updates from you?

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service