Let's put this in here so everyone can start to post reports and get their devices working. 

Tested and OK devices:

- Samsung Galaxy Note II (AND_4.1.2) - (19.02.13)

- Samsung Galaxy S3 (AND 4.1.1) - (19.02.13)

- Samsung SIII, (AND 4.1.2) -  (21.02.13)

HTC One X+ (AND 4.1.2) - (21.02.13)

Acer Iconia A500 (Thors ROM) - (28.02.13)

- T-PAD IS709C, (AND 4.0.3) - (03.03.13)

Motorloa Photon XT897 (AND 4.0.4) - (05.03.13)

- Samsung 8" Note (AND 4.1.2) - (25.04.13)

Asus TF300T and TF300TG


Tested but having problems:

- Oker TP-703 tablet (AND_4.1.1) - no link (19.02.13)

So if you have a device that you tested and it is working or not working, please post in here so we can update list, Please include your android OS version too.

Views: 6826

Replies to This Discussion

Hmm...I followed the steps on link below to add external power to my existing OTG cable http://forum.xda-developers.com/showthread.php?t=1828032 - still no luck with getting it to connect same error (yes I checked my handy work on the cable with a metre, with it connected to external power, but not the phone, it reads 5v at the female plug :) )..... As I suspected its a software issue with the HTC OTG support, I suspect it is missing drivers? I tried the app and cable with my partners S4 Galaxy and even without an external power source it worked fine first try. Any ideas? Cheers

Oh I think I just found an answer to my question...DSLR APP: http://dslrcontroller.com/devices.php

USB host support is broken on the standard firmware, custom kernel is currently required.

Might try this. Will update wiki once I confirm it works.

7" Cheap Chinese called Xtreme tablet 7C Droid 4.0.4

This tablet does not work with goggle play so download latest adropilot here

https://github.com/geeksville/arduleader/downloads. Obviously then look in your downloads click and install 

Also the tablet does not come with usb host mode on so,

 - Install "USB Host Check" from a place called Aptoide [ remember googleplay isn't supported]. Or any other app that sets the tablet in usb hoist mode.

 - Run the app and press Fix. All items should be with a green check.

 - Reboot tablet.

 - Connect 3DR with this


If it doesn't work find googleplay and instal. It won't work but andropilot needs to see the app installed as I recall.

Also... this is not the one I have but I bet it would work if you can set it in usb host mode the same way as above. Plus this one has google play so a bit less screwing around finding USB Host Check.



Good find!  Btw - that build is _really_ old - I thought github had turned off their downloads feature.

Here's a current version of andropilot for you.  I'll find a way to start hosting this on a 3dr server or somesuch.

I was wondering where all those super old versions were still coming from... ;-)


Wow that's great thanks!! And thanks for such a GREAT app!!! 

FYI for anybody with this tablet the newest version doesn't work. Definitely related to the fact google services doesn't work. It does work with the older version and google services installed... but doesn't work. If that makes sense. 


I am using PIPO Android Tab v 4.11. So far, i have done several flights using this tab.  Different modes were tested such as Guided, Waypoints, RTL, Disarm, Alt Hold, Acro, Land. This tab is working properly as it should. PIPO, by the way, is one of the cheapest Chinese made tab.


This cheap 9" Chinese tablet works great with andropilot!!!  They also have a 7" I suspect it would work fine. Might have to get a utility app to turn on usb to 'host' mode for the 7" but I didn't need to do that with the 9". Gotta find the apk files outside of google play as the tablet does not support googleplay. Here's a direct link to the latest andropilot andropilot-2.0.01-market.apk Thanks Kevin. Note you need to find and install google play and googleplay services, They can be installed but they will not run. I guess they didn't want to pay the three headed monster google Inc a royalty fee. However it seems abdropilot needs to see those apps installed. The fact they don't work is beside the point. fyi this tablet does NOT come with an internal gps. It can work with a usb gps which would be useless as we need the usb for the telem module. Oh and another fyi this guy sells a really nice tablet holder that works well with some Futaba handles that are plastic or any other transmitter for that matter. 



Oukitel Original One O901 4.5 Inch Android 4.4 K78 Cell Phone MTK6582 Quad Core 512MB/4GB 3G WCDMA OTG

But the GPS is not real so any mode requiring the phones gps won't work.


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service