I am trying to setup and to configure my APM 3.1 mini with FliteTest Blunt Nose Versa flying wing and ArduPlane 3.4 firmware. I have more or less everything connected, setup, configured and working, but only missing thing is arming via rudder.

I do not use rudder to control airplane, since it is flying wing and that it is why it has only two servos. But to be able to arm APM, I configured channel 4 to be controlled with my rudder stick and as I see from the Mission Planner, it controls Yaw values in range 982 - 2013.

But I am not able to arm with it at all. Arming via USB cable works. But not arming with rudder at all.

I tried to change:

ARMING_CHECK to 0, but it did not help.

ARMING_REQUIRE to 1 and to 2, but it did not help.

ARMING_RUDDER to 1 and 0 and it also did not help.

I tried to arm APM in manual mode with throttle at minimum. Also tried if Roll will not arm, but it also did not help.

Throttle value is in the range 982 - 2013. Throttle failsafe is set to 950.

Could you help me, please?

Views: 732

Replies to This Discussion

It won't ARM if its unhappy with something.  Are you seeing anything on the GCS that might prevent arming?

Thanks, Grant.

Hi Grant, Thanks for reply. I just got it working with extending value limits on radio as Tom suggested, thanks. It seems to like value 942 and lower to be able to arm. I also have to adjust Throttle failsafe value functionality which was 950 by default to not start RTL automatically with such low throttle value, I put it to 915. The question I am asking is why APM does require so low throttle value and does not use normal throttle calibrated minimum value to be able to arm, please? Thanks. Regards, Pavel

maybe throttle is reverse.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service