Dear friends, have a bit of a mystery I could use some help unraveling. I was flying my EasyStar II testing platform yesterday (FPV, Telem, LiPolice ESC/Engine, fiberglass reinforced) when the pre-flight check Gods bit me for having too much weight in the nose. The plane came down at a 30 degree angle with a good bit of speed and when it hit the ground it was not softly.

Amazingly, when I got to my plane it looked like the rain from the night before had softened the ground. The battery had come loose and some wires were detached, but there was no structural damage (thank God for fiberglass). Now comes the strange bit...

After 20 minutes of reattaching everything, checking it over and ground testing, I was ready to fly. I pushed the stick upwards and... no throttle at 10%, 20%... up to 60% at which time the engine went on it's merry way. Got another 20 minutes of flying done without major issue, but the dead stick to 60% stayed! I tried pulling the battery, checking the cells, rebooting APM 2, checking its settings, no joy on any of them. I can't figure out what this could be. Video indicated that APM through I was flying at 70-80% throttle, which is about where the stick was, so it looks like the throttle signal was fine at least up where the APM's sensors read it. Does anyone have any thoughts on what might be the issue?

Best,
Robert

Views: 305

Replies are closed for this discussion.

Replies to This Discussion

There is a procedure for resetting your throttle 0 position
This works for all the ESCs that I have had...

Turn your TX on and set full throttle
Turn your RX on and wait for the beeps to stop
Set 0 throttle
Esc should beep
Should be all good now

Phil

Damaged ESC? Did you already try to recalibrate throttle range? Weird things can happen in crashes.

Try connecting a servo to APM output throttle channel, it should move along the throttle stick movement, if not the fault is in APM (settings?).

Many thanks for the reply Philip, I did as you suggested and the ESC went into programming mode, cycling through the options repeatedly. I am trying to track down the instructions for the ESC to figure out what the beep codes are and whether there is a throttle calibration setting. Will let you know if it works!

Thanks again,
Robert

Thanks Picea, 

Will do that as well. It seems strange to have damaged the ESC in such a way that it works fine at higher throttle settings, but not below. I'm not technical enough to know for sure though. It is clearly an issue between the APM output and the ESC though.

Thanx,

Robert

Which esc is it

Good news! You were right Philip, it was indeed the ESC programming. Once I tracked down the correct ESC (Multiplex 30A instead of the LiPolice I thought I had ordered) I reprogrammed it and now my throttle behavior is back to normal.

With this problem solved I can finally test the FBW B and Auto modes on my FPV bird, can't wait to get back out to the field to test it.

Thanks again for the good advice!

Robert

Good to hear, what was the procedure to fix it, for the next person?

Phil
Of course, best idea is to take a look at the Manual at http://www.multiplex-rc.de/fileadmin/content/dateien/downloads/eb_m... all the instructions for setting the throttle min/max are there, as well as all the other programming features for this ESC.

Best,
Robert

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service