Me again with another query - hoping someone can help me out again!

I have my X-5 wing flying nicely baselined in manual mode but every time I try FBWA mode I have almost no response and have to revert to manual just to complete a turn at my local model club. Same thing goes for Autotune mode. I have double checked the LIM_ROL_CD, LIM_PITCH_MAX and LIM_PITCH_MIN parameters and they seem to be high enough (4500 and 2000/2500 respectively) so what could be wrong?

I also did a little ground check by holding over aileron all the way to one side, then slowly banking the aircraft over (in my hand). Sure enough, when it gets to around 20 degrees bank angle, the elevons are level with each other which would seem to indicate that LIM_ROL_CD is too low (certainly well below 45 degrees!).

I have done some searches on this issue and the reason for sluggishness for others was too low settings for these parameters, but I'm at a loss for my problems!

Thanks,

Jacques

Views: 3175

Replies to This Discussion

Jacques,

Those parameters set the roll and pitch limits, but the actual responsiveness of flight controls is determined by the roll and pitch PID controllers. Have you worked through the tuning section of the manual? If not, you will want to read these pages:

http://plane.ardupilot.com/wiki/tuning/

If your proportional gains are too low, you will get the sluggish performance that you describe. You will want to do a flight using AUTOTUNE to set these gains automatically, but if the performance is too sluggish to even fly in autotune, then you will manually need to raise the proportional gains beforehand. I hope that helps!

Mark

Could it be the anti-stall measures?

I had similar problems, but perhaps not as extreme as you describe when I maidened a Go Discover. I had the pitot tube/airspeed settings wrong so the APM thought I had zero airspeed. That of course is below the minimum airspeed setting so it restricted the roll angle to 25 degrees. I had very long gentle turns, and with a flying wing there is no option of using the rudder to help.

On my flying wing (Falcon) I had a similar issue.  I have LIM_ROL_CD set to 6000, LIM_PITCH_MAX at 2500 and my NAVL1_PERIOD set to 11.  My RLL2SRV_RMAX is 90.  Note I have an APM2 but its the same code.

You need to post a log (preferably dataflash) for us to investigate if you cannot resolve it.

Thanks, Grant

have you disabled elevon mixing on the TX and enabled elevon output mixing in the controller?

Thanks for your reply, Mark.

Yes, I have tried autotune in a few flights and recorded a gradual increase in RLL2SRV_P (0.4 to 0.656) and PTCH2SRV_P (0.4 to 0.463). NAVL1_PERIOD stayed on 20. But it's been difficult with so little movement that I kept having to flick back to manual to keep it within the bounds of my flying location. I will try method 2 of the pitch and roll control tuning in my next outing.

Jacques

Thanks for your reply, moglos. On the basis that I don't have a pitot tube I doubt that could be the cause.

Verify then that you have the settings correct. If APM is set to use a pitot and there is none then it might registering speed =0.

There are two settings in the hardware setup section, from memory to say if a pitot is present, and to say if APM should use them.

Another way to check would be to verify that the airspeed and groundspeed is the same (watch the left of the HUD during a flight, or while replaying one).

Thanks for your reply, Grant. I am going to try method 2 for pitch and roll tuning and play around with RLL2SRV_P,  RLL2SRV_D and RLL2SRV_I as suggested in the tuning manual. If I'm still having issues then I'll post a log.

Jacques

Thanks for your reply, Dwgsprky. I confirm that my Tx is set up as a normal model (with tail) and I'm using Pixhawk for all my mixing (elevon_output - the newer method).

Jacques

Jacques

I remember reading this a few weeks ago from someone who was having a similar problem, and wonder if it could be the same or a similar issue?


http://flitetest.com/articles/pixhawk-fbw-a-autotune-lethargic-reso...

My Falcon wing will be completely different to your wing and I have an APM2 in it but just in case you are curious I have attached my parameters file.

Thanks, Grant.

Attachments:

Ben/Jacques

I'm having the same issues, limited roll in FBWA mode, with the roll limited to about 15 degrees of bank despite the LIM_ROLL_CD parameter being set at 4500. Giant slow circles with limited climb on take off.

Yet if I change to AUTO mode the roll limit is exactly as expected at bang on 45 degrees.

If I increase LIM_ROLL_CD to 6000 the roll limit does increase in FBWA but then it is at 60 degrees when I change to auto mode, which is too much.

Ben, the link that you have posted seems to say that the ppm values are being reduced by the FBWA mode and the solution is to increase the ppm values, could someone tell me how to do this without affecting the other flight modes.

I have only referred to roll but pitch is similarly affected.

Thanks.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service