Uploading Firmware to APM 2.6 using APM Planner works, but "Connect" doesnt.

Hi everyone,

i am using a MAC, and did install the FTDIUSBSerrialdriver_10_4_10_5_10_6_10_7 that comes in the APM Planner package. And it seems that my APM 2.6 works, as i can upload the Plane Firmware using the Planner.

But if i then try to connect using the top right corner-button, it "shows connected" and nothing happens.

Its shows no MAVlink prompt or so, and no Data at all is shown in the Flight Data Section.

I guess i missed something simple. All posts about connection problems i have found so far, are about COMPORT issues. But in my case i can upload Firmware using USBMODEM1411 at 115200 baud.

Maybe someone knows more?

Thank you!

Views: 311

Replies to This Discussion

What version of APM Planner 2.0 are you using? if you are not using the latest (which would seem likely as APM2.x FW update is broken in that version), you'll need this version mentioned in this thread here http://ardupilot.com/forum/viewtopic.php?f=82&t=13256

Hi Bill,

thanks! I already used exactly that link. I thought i should see at least a Roll/Pitch in the Primary Flight Display. I tried to delete all files from previous Planner versions and reinstalled it, but again, Firmware install works fine, but still no input signals from APM to the Planner. I tried a reset of the APM just to see, but no luck.

This person has just done the same setup as you but works. http://diydrones.com/forum/topics/mac-os-apm-2-6-firmware-load-erro...

My guess is that you have a fault on the board 3.3v regulator it would seem. Try booting the APM while connected using the Terminal Console in APM Planner

Mmh, it says:

No such file or directory

Please ensure you have disconnected from the UAS, before connecting using terminal mode.



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service