Ciao a tutti
Apro questa discussione per dar modo a chiunque avesse interesse per questa piattaforma a mio avviso sottovalutata di poter postare le proprie esperienze o porre i propri quesiti.
Io volo attualmente con un minititan 450 con apm 2.6 mini pro e mi sta dando un bel pò di soddisfazioni.
Loiter althold ed auto proprio ieri.

Saluti a tutti

Views: 267

Replies to This Discussion

Buongiorno, vedo che questo post è datato, spero qualcuno mi risponda.

Scrivo quì per non avere noie con l'inglese, ma se necessario scriverò in altre discussioni in inglese.

La mia storia, in breve: sono delle Marche e appassionato di elicotteri RC tradizionali; in circa 15 anni di elicotteri RC (e 25 di modellismo RC in generale) ho provato diversi elicotteri, prima a scoppio poi elettrici, con flybar, e poi molte centraline flybarless;

Posseggo ora dal 2012 un Mikado Logo 500SE (per chi non lo sapesse è il 500 strecciato per pale da 600), lo conosco quindo molto bene, e lo ho sperimentato per varie centraline flybarless sempre con successo; volendo avere il volo automatico ho quindi acquistato l'anno scorso, delle Pixhawk 2.4.8 (clone) con GPS M8N;

Prima domanda: tutte le SD fornite con detti cloni, da 4GB, anche usata su aereo, registrano dataflash logs indecifrabili; strano è che le micro SD fornite con detti cloni di Pixhawk funzionano bene per altri utilizzi su PC, ma con Pixhawk non ne vuol sapere, provata a riformattare con Windows e altri programmi, anche in FAT 16, aggiornato Mission Planner con ultimi firmware sia di aereo che elicottero, ma niente, registra (viene occupata memoria dopo le sessioni di volo) ma poi Mission Planner (e in windows, dentro la cartella LOG ci sono nomi file indecifrabili con caratteri strani) non legge i dataflash log; sostituite con altre micro SD mie e registro senza problemi; visto che non voglio acquistare micro SD per ogni Pixhawk, in cui vengono fornite e che sembrano buone, la domanda è perchè avviene questo?

Secondo problema:

Premessa: con una Pixhawk identica, con identico GPS M8N, montata su un aereo non ho avuto problemi, ho letto in diversi giorni la guida Arducopter online, scaricato la versione Mission Planner (l'anno scorso era la 1.3.41), flashiata con relativo firmware, calibrati accelerometri e magnetometri, settato con i parametri di default, primo volo; poi autotuning, poi in automatico senza problemi;

invece il mio elicottero, sempre letto la guida Arducopter, anche quella specifica per Traditional Helicopters, installato il firmware per ely tradizionali, calibrati accelerometri in piano (in Mission Planner corrispondono bene le inclinazione al banco rispetto l'orizzonte artificiale), calibrati i magnetometri, sempre con GPS M8N, abbastanza precisi se riscontrati con riferimenti che posseggo riguardo il nord, sud, ecc, settato e trimmato da Mission Planner il piatto a 3 servi, fatto il primo volo coi parametri di default, corretti tramite inflight tuning secondo il manuale, non effettuato però autotuning in quanto non riportato sulla guida per Traditional Helicopters, succede che in modalità stabilize, Alt Hold (tiene solo bene la quota), PosHold e Loiter, non si autolivella, e devo tenere gli stick del pitch e roll sempre a mano: dai grafici dei dataflash log, plottando mechanical failure, si ha nel corso del volo una differenza a volte di oltre 10 gradi fra l'inclinazione effettiva e quella desiderata; ne consegue che in loiter se lascio i comandi, comincia ad inclinarsi credo dalla parte dove soffia il vento, poi grazie al gps pian piano contrasta, ma poi va troppo contro il vento e ritorna dalla parte in cui era scappato prima, e l'oscillazione diverge, se non aiutato e corretto con gli stick; questo sempre, salvo la sera quando il vento è totalmente assente.

Quindi, volando in AltHold, tiene bene la quota e apparentemente è stabile, ma da radio devo contrastare, tenendo gli stick anche a metà corsa e oltre, il vento. Se li lascio si inclina sia su pitch che roll, fino a 8/10 gradi nel verso dove soffia il vento.

La domanda è: posso tentare un autotuning senza rischiare di distruggerlo o il problema non è di tuning dei PID, e quale potrebbe essere?

Ora mentre scrivo non sono nel luogo in cui ho l'elicottero col PC e i dataflash log, quindi se qualcuno risponde ed è disponibile, quanto prima allego il dataflash log di un volo (gli altri sono praticamente gemelli e hanno il medesimo problema, quindi l'uno vale l'altro).

Grazie.

Buona sera sig Enzo.

Vedo che questo post è datato,ma sono molto interessato a questo argomento su Hely tradizionale.Comunque mi scuso,sono nuovo,se sbaglio su qualcosa mi scusi tanto.Desidero scrivermi a questo gruppo da lei indicato,ma vorrei guidato a come fare per registrarmi,La ringrazio.Sono un appassionato del volo RC sia con Droni che Helicopter,ma sono un po' grande 72 anni e non ho piu' lo sprint di una volta--Ho effettuato il setup di un drone classe 250 e di un altro 330  con  FC OmnibusF4 Led strip settata con INAV  e volano abbastanza stabilmente,eseguono Alt Hold e il ritorno a Home  e il FailSafe con precisione. 

Posseggo un Hely classe 500 clone T-Rex che ho settato con HelyCommand,e vola bene,ma pultroppo non esegue voli

automatizzati.

Avendo acquistato da tempo,una flight controller APM 2.8 che ho provato varie volte su droni,si li ho messi in volo ma non sono mai riuscito a settate Alt Hold ne il ritorno alla Home ne tanto meno il FailSafe ecc.

Come le dicevo sono molto appassionato al volo Automatico,ma pultroppo sono un principiante,molto praticone,che ho imparato facendo pratica da solo e senza mai l'aiuto di qualcuno.

Attualmente sto cercando di Settare un Hely classe 450 clone T-rex con APM 2.8 con Mission Planet,Firmware 3.2.1 ,

effettivamente in rete non sono riuscito a trovare una guida valida che mi aiutasse,ho avuto molti problemi con il setup

dei servi del Piatto ciclico,che nonostante funzinassero nel modo giusto,avevano un tremolio e si surriscaldavano,finalmente

sono riuscito a settarli che vanno bene e non riscaldano,ma adesso sono fermo al punto che al programma non mi permette

di impostare ne la curva del Gas,ne la curva del Pitch, alla Radio che è una FlySky I6x impostata per Aereo Glid,c'è l'opzione per impostare la curva del Gas,ma nonostante la imposto alla Radio,non viene eseguita come io la imposto,di fatto il motore parte subito al massimo della potenza già al 50% dello stick del gas,creando i problemi che di certo voi capite.

Ho settato anche un'altro Hely 450 con una FC CC3D revolution, con il programma Libre Pilot e sono riuscito a metterlo in

volo ed è abbastaza stabile ma anche li sto avendo problemi a settare la posizione del GPS+Magn Neo 8M,di solito questo

Magnetometro è sfasato di 180 di Roll,nonostante lo imposto corretto con cento prove,come il GPS fa il FIX l'orizonte

artificiale sembra impazzito, si muove incoerentemente in tutti i sensi.

La ringrazio in anticipo se puo' darmi una dritta e mi scusi tanto se sono stato molto lungo nella richiesta--

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service