merhaba,

ardupilot 2.8 var elimde MP girip Install Firmware kısmında quadcopter için gerekli yüklemeyi yaptık dan sonra connect yapınca 'you cannot load new firmware while connected via mavlink' hatası alıyorum. bir türlü aşamadım bu sorunu yardımcı olursanız sevinirim.

Views: 515

Replies to This Discussion

Merhaba, aynısı bende de oluyordu fakat nasıl çözdüğümü tam hatırlayamıyorum. Şimdilik önerebileceklerim en son seviye firmware'e yükseltmen, com portu ve yanındaki bpsini doğru seçmen. Bende Pixhawk var ve auto ile kendisi seçiyor. Genelde com 3 ve 115200bps olarak bağlanıyorum. Bunlar işe yaramazsa hatırlamak için biraz daha zorlayacağım kendimi :)

Firmware yuklemeden once disconnect demeniz gerekiyor. Yukleme islemi bittikten sonra emin olmak acisinda kablosunuzu veya alicinizi sokun, mp yi kapatin tekrar acin, comport listten dogru olan portu secin usb icin 115200 3dr rf modul icin 57600 baund diye hatirliyorum sevtikten sonra baglanmayi deneyin. Olmazsa ekran resmi alin yardimci olurum.

merhaba, en güncel sürümdeyim. com5 ve 115200bps olarak bağlanıyorum auto desemde bununla bağlanıyor. hala çözümüm yok :(

tam olarak demek istediğinizi anlamadım zaten disconnect durumdayım. quadcopter seçimi yaptıkdan sonra connet diyorum ve yukardaki hatayı alıyorum. size 2 foto atıyorum ilk foto ardupilot bağlı ve firmware yüklemesi ama connect olamış hali 2. foto ise connect dedikten sonrası

Attachments:

arkadaşlar şu soruna bir çözümü olan yok mu?

Umarım geçen sürede sorununuzu çözmüşsünüzdür, Söz konusu bağlantıyı kablo ile mi yoksa kablosuz (MavLink radio) ile mi yapıyordunuz?

Merhabalar,

Oldukça geç bir cevap olucak ama, belki benzer sorunu yaşayanlar için cevaplamak istedim.

Pixhawk veya ardu otopilotları bağlantı (connect) yaptıktan sonra firmware yükleyemezsiniz. Firmware mission planner üzerinden disconnect yaptıktan sonra kurmanız gerek.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service