I've been battling my new 3DR Y6B for 2 days. One motor wouldn't start up. Found that problem, I had the wire from the ESC plugged in upside down. Now that motor was working, but another motor was dead !!!

I remembered reading somewhere on this forum, about a bad connection on the power distribution board. Got out my multimeter, and sure enough, on the underside of the PDB, (+ side), I had no contact. Rather than take the top plate back off, I just soldered that ESC hot wire, to the positive terminal on the PDB. "IT LIVES" However I'm concerned about the rest of the connections on that board. It was VERY hard to plug in the Deans connectors to the board, and perhaps that led to a broke solder joint. I'll make her fly for a little bit, just to know "I WON", then maybe break it back down and re-do that PDB setup.

Views: 300

Replies to This Discussion

I just started my Y6 build. Got the deal from 3DR. Hopefully all goes well. Still have my IRIS+ if all else fails.

It's a pretty neat kit. I bought 2 of them at $249 each. One kit was missing the 6 motor mount plates, but I decided on using the stock metal motor mounts instead. Works pretty well. I'll probably put mine in the air, today or tomorrow. Packing all the wires is a pain, but all part of it. All in all, pretty neat getting a whole Y6 for what just the Pixhawk alone used to sell for.

OK, got everything stuffed back together, and just did a test flight. Only in stabilize mode, as I don't have all the channels setup yet on my Taranis. It flys! Tail drags when you give it hard throttle, and the bottom rear motor (was neither of the other 2 troubles above) seems slow. Probably another bad place on the PDB.

TIP! If you ever start to put one of these together, 1st thing you should do is throw that PDB board in the trash!

I'll probably wind up tearing the whole thing back down to the bare bones, and solder in a decent PDB board, no Deans, etc. etc. and run the ESC wires straight to the Pixhawk.

OK, after having one ESC go up in smoke, I tore it back down. Took out that damned 3DR power distribution board, cut the Deans connectors off the ESC's, and soldered everything to a plain PDB board I had laying around. Ran the ESC wires straight to the Pixhawk. Calibrated the ESC's, and everything works perfect! Test flew for 4 or 5 minutes on a brand new 10000 mah 4C Multistar battery pack. I'm happy. Now just have to do the "re-packing" of all the wires, etc. etc. Will add a gimble later.

Well, seeing as how this forum seems pretty quiet, I thought I'd add some. My Y6 is flying nice! I've added a 2 watt video transmitter, (Black Mamba), a mini 3 axis gimble, with a GoPro 3. Camera pitch controlled by knob on my Taranis transmitter. Still have to hook up a voltage sensor, get everything nice and tidy, set transmitter voice warnings, and go film some. Been nasty down here in Florida for the past few days, so maybe today is the day.

Attachments:

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service