I built an APM 2.5 and had very little problems, but on my APM 2.6 I am not able to get my PC to recognize Arduino Mega 2560.  I downloaded the zip file and extracted it.  Then I went to "Other Devices" and scanned, but no luck.  I do not see the Arduino Mega 2560.  Also, if I plug in the USB cable from the APM 2.6 to the PC, I am getting power and the GPS locks in.

I disabled the "Driver Signature Enforcement", but still no luck.

Any assistance would be greatly appreciated.  

Views: 7861

Replies to This Discussion

I should add, I am able to use the USB telemetry and have calibrated everything, but the Compassmot.  I plan to do that procedure next once the Arduino Mega 2560 problem is solved.

Did you install this driver?


@Daniel, APM 2.5 and APM 2.6 has no any differences from USB perspective. They both uses same firmwares on main cpu and also on 32u2 chips. Only difference is that 2.6 do not have compass chip installed on board. 

@Chris, if 2.5 works then 2.6 should work fine too so this must be something else.

@Daniel, are you using 3DR or jDrones made APMs or some Chinese clones? Why asking, well there are only jDrones and 3DR originated electronics are following original design and components others have some other components that might cause problems for you.

I am using 3DR electronics. Also, I have the latest Arduino Mega 2560 driver. - same as Chris recommended.

I tried a different computer and USB cable, but still the same results. I should add, when I plug in my APM 2.5 hex, the Arduino Mega 2.5 is recognized on both computers.

I'm using Windows 7 64bit PC's.

Ok, then without seeing the hardware in my hand it sounds like  you have an broken hardware at your hands. Please contact 3DR customer support on this issue. Maybe a bootloader, mcu or somethings else. Really hard to say without seeing your board.

I agree.

I contacted 3dRobotics support.


While waiting for support, I thought I would continue looking for a solution for my APM problem.  I think I solved it, and this is what I did.

First, I erased my calibrations/settings through the Mission Planner. Then I exited the Mission planner, and disconnected the USB from the PC while rebooting the computer.  Then I plugged the USB from the APM 2.6 to the PC. At that time the Arduino Mega 2560 driver installed and I was able to update the firmware within Mission Planner.  

I still have to do the Motor Test and Compassmot, but at least I now can complete the tasks.  

So far, so good.


Well, I guess That didn't solve the problem.

After work, I thought I would plug the APM 2.6 to the PC using the USB cable.  It decided not to connect.  Note:  Although, power does go to the APM.

"USB device not Recognized"

Any suggestions while waiting for support would be greatly appreciated?

I think I finally solved the problem.  It was the USB cable (new).  I realized the possibility from another individual who seemingly tried everything too.  Through all of my trouble shooting, I some how missed the possibility of the cable being faulty.  Part of the problem was it would randomly work, such as when I tried it on my hexacopter.  

I should add, 3DRobotics support was available and helpful in a timely manner. 


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service