While flying my APM 2.6, my quad went into RTL.  Based upon my log, the RTL was triggered by the low voltage (10.5).  Although, I don't understand why, because I had the failsafe options disabled.

I was flying my F450 in the woods so I didn't want the copter to rip into the trees.  Well, it did, straight up. Thankfully, I had three tough Graupner props that sacrifice their lives to part from the tree branches 40 feet above the ground.

Damage - 1x broken arm and 3x props.

I would like to know why the copter went into RTL when I had the option disabled in the Wizard - Failsafe.

Attached is the tlog.

Thanks in advance.

Views: 2850

Attachments:

Replies to This Discussion

Attached is a jpeg of the Failsafe options when the APM 2.6 went into RTL.

I had the Failsafe disabled in the box with the "Battery Low" 10.5 Volts for my 5000 mAh, 3 cell Lipo.  Should I have disabled the RTL option below the box too.  - Refer to the attached jpeg.

Thanks again.

Attachments:
After going though the advanced perimeters, I discovered the low voltage was set to RTL. Maybe it is just me, but the interface layout in the Wizard - Failsafe is not clear. The voltage FS option to enable or disable should be next to the Low Voltage setting. Also, the interface on the Failsafe tutorial page is not the same as the current version of the Mission Planner.

I'm sure most of the time individuals will want the Failsafe options on, but beware if you think you have them off when flying in a woods. :) - lesson learned.

Is it possible to consider updating the displayed enable/disable Failsafe options on the Failsafe page in Mission Planner to fool proof selection/choices?

Thanks.

Daniel,

Good news that you figured out the issue.

To increase the chance that MichaelO sees this request, could you raise it in the mission planner issue list?

For, me, when I include a request on a change to where to place buttons, etc on the mission planner I often include a screen shot to make it easier to understand what I mean.

Okay.  I will send a request to the mission planner issue list.

Thanks for the reply.

Just curious.  Is there a way to get out of a RTL triggered by Failsafe "Low Voltage"?  I assume there isn't, but I want to make sure if I can avoid another mishap. 

Also, I sent a Mission Planner Issue List request per the Battery Failsafe enable and disable placement.

Thanks again.

To get out of any failsafe I think you just have toggle the flight mode switch back to Stabilise. If you are already in stabilise then you need to toggle to another mode and then back to stabilise.

I have a dedicated "Oh Crap" switch on my Futaba T8FG that drops the PWM to the range for stabilise regardless of which flight mode I am in. So this way if i need to regain control I dont need to toggle flight mode switches back and forth. I just hit the Oh Crap switch.

I was in stabilize mode and toggled the mode switch, but it didn't go back to stabilize mode.  I only had approx. 5 seconds for correction due to flying in the woods.  I looked at the log and it did not indicate the attempt to switch modes, and back to stabilize.

I know I can get out of RTL in other Failsafes, but can the FC cancel/toggle out of RTL in a low battery failsafe situation?  As noted, I don't believe I had enough time to get out of the RTL mode due to flying underneath tree limbs in a woods.  I just would like to know so I can be better prepared for the next time.

Thanks.  

If the copter is armed and props running on the ground in stab mode, what should it do if switched to RTL? This is for Pixhawk.

I was in stab mode and only four or five feet from the home position.  The altitude was approx. five feet.  In your case, I'm sure it would do the same thing by going straight up.  - Very little time to correct if you don't have the headroom.  In my situation, I wanted all of the failsafes off.  I'm still waiting to hear if I can change the RTL back to Stab if the Low Voltage Failsafe activates.  In my case, I didn't have enough time, but I would still like to know.  Note:  I thought the Low Voltage Failsafe was disabled per an attached image of the Failsafe page in one of my previous replies.  I found out it wasn't after the RTL crash.  The FS Low Voltage setting in the Advanced parameters showed it was enabled.    

I believe the enable/disable selections need to be positioned next to each Failsafe option to be more fool proof. Currently they are not.  For safety features, there shouldn't be any question what is disabled or enabled regarding the Failsafe choices.  I hope there would be consideration to update the display placement of the enable/disable options.         

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service