I'm about to finish my first Arducoper! :) But, I'm having trouble getting the ESC's to calibrate properly. I'm using a 9x (stock at the moment) and it seems to be all good.

  I get the beeps at intervals with the ESC control disconnected and I get the start up melody when they are connected and then they go silent.

  I think it might be my radio calibration. I've gone threw the wiki and that's what I come up with. The one thing I don't understand is the 100% asked for before doing the all at once calibration.

 My radio doesn't push the full scale 100% top to bottom but it does a good portion of the scale. Is this my problem you think? Or is it something else? It's a bone stock APM 1

  Also I noticed with the GPS pluged in it seems to brown out the APM? So I've just left that unpluged for now. I figure I'll figure that out after I cal the ESC's



Views: 932

Replies to This Discussion

The APM auto-calibration doesn't always work.  But if you use that, it shouldn't depend on your radio or its calibration, since the software sends the calibrations sequence using the APM pwm generator.  Suggest you do individual calibration of each esc using your radio.

Are you using the stock (yellow) ESCs that come in an Arducopter kit?  I used those and was unable to get them to calibrate either automatically or individually.  It turns out that some of the ESCs shipped by 3DRobotics have a firmware that doesn't allow them to be calibrated, even though the paper instructions that come with them suggests that they are calibratable (if that's a word).  I wrote to the nice folks at the DIYDrones store and they shipped me a set with updated firmware (after I returned the old ones.)

The issue of your radio not being at 100% wouldn't matter unless you'd set a "custom curve" to decrease the radio's scale.  I'm guessing your stock 9x is not the issue.


BTW, this problem made me crazy for a week until I found mention of someone else with this situation on another part of the DIYDrones forum.  The best part of working on an arducopter is the community of people who help figure out your issues...

The arming issue could be radio calibration.  Check all your trims on the radio, they all should be centred.

Ok, centre everything and re-calibrate the radio.

I had a similar issue when I first set up my 3DR quad and I had to set my throttle trim all the way down to get things to work correctly.

Yikes.  Do they have a warranty?  I've had a few ESCs smoke before.  They're still flying.  The SS Esc from HK, have a overheat protection.

Shouldn't be a problem unless something got shorted.

That's what I did this afternoon and it worked fine. Now I just need to find out how to assign the F MODE switch to channel 5 on a Turnigy 9X. Going through the Turnigy's function menu, I can't seem to find that switch as an option for channel 5.

Don, a little off topic, but you set the Aux channels under "AUX-CH".  That's the last item on the last page of the setup.

Assign one of the "trim" pots to the mode switch, under CH5.

I also had trouble setting up the Turnigy 9x v2 Mode2 and its reciever v2
that came with it. (Bought in April 2012) This is how I got everything to
On the Turnigy 9x v2 Mode2: a) trim your rudder down as far as it will go. b) Reverse the Throttle and Elevators (Menu / Func Setting / Reverse) c) Make it Mode 2 at the sticks (Menu / System Settings / Sick Set) d) You should be in Acro Mode (Menu / System Settings /Type Sele) e) Set it to PPM (Menu / System Settings / ModeUAT) f) Set Aux ch 5 = pit trim  ch6 = hov pit (Menu / Func Setting / AUX-CH) g) Set timer for how long you want to fly (Menu / Func Setting / Timer)ACT 015  000  (for 15 min flight) then you use TRN switch on Transmitter to turn timer on/off
Bind your reciever to the transmitter. On recierver 9x8c v2 that came with my transmitter, put binding plug in position 9 not 10 as it looks like. Battery is on 10 (Power from PDB). This really confused me at first.
In Mission Planner: a) re calibrate your radio. (configuration / radio calibration) don’t reverse anything here b) I set my flight modes for first testing at Mode 1 = Loiter  Mode 2= Stabilize  Mode 3= Stabilize  Mode 4= Alt Hold   Mode 5= Stabilize (simple mode)  Mode 6= Stabilize  (simple mode)
Hopefully I didn’t forget something, its 3am here. If you need more help feel free to contact me and I will compare all my settings with you.
I flew my Hex Aerial Thing (HAT) 2 days ago and yesterday. 3DR Hexa body with APM2.  I got the larder 880kv motors using APC 11x4.7 props with 5000 mah lipo battery. Great flights and some greater crashes (my mistakes I
think) All OK but some  broken props and broken motor wire I fixed, so not
bad for my very first flights.
First Flight it got right up in the air. ( by the ground is not as stable and that’s normal) Then I turn mode to ALT HOLD and it took off upward real fast and I paniced and tried to turn back to Stabilize and it started falling fast but staying level. At the last I gunned it and it landed and went down about 18inches in the snow. Yep I live in Alaska and still have snow. Lucky it was late in day and snow was very soft, not froze hare. It landed flat and I only broke two props. I need to water resist my unit better.
Second Flight I stayed on Stable and did fine, lots of takeoffs and landings. I flew until I lost control (my fault) and tried to mow down a tree in my yard. 3 more props broken.
Third Flight I started on stable mode and flew around doing fine so put it on Loiter Mode and it did its thing correctly. GREAT it just hung there without my control. Again flew around till I tried to make it eat another tree.  Broke motor wire were it connects. I plan later on putting wire a different route than going in the end of the tube. Also lost the E-Clip off bottom of one motor and had to replace it.
Yep I have never flown anything and am trying to learn fast befor I go


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service