Hi guys.

I've build several DJI crafts, 2 quads and a hex.

I picked up another DJI Quad with the motors, props, ESCs with the intention to try with APM2.5.

So I have it all wired up. Since the DJI ESC do not have a BEC, I added another just to power everything up.

On my first attempt to fly it immediately/violently flipped over to the right.

I did the motor test and say I had swapped front right and back right wires.

Corrected that, and just to be safe redid the auto ESC calibration.

Redid the motor test and everything spun the right way (and yes I have the right props and the APM is pointing the right direction).

But the problem persists. A violent flip over to the right.

Luckly I have not broken any props yet.

Any ideas?

Views: 1431

Replies to This Discussion

I had the same problem with HIL testing in xPLane. Just continued to flip over on power up. Using 2.7 HIL Quad-X. Haven't tried on real quad yet. 

Quick thought - have you checked the motor numbering? DJI and ArduCopter have different numbering schemes. DJI from front right anti-clockwise in X format is 1,2,3,4 but ArduCopter is 1,3,2,4

Yeah I saw that when I started the build

And in truth I did have them mixed up initially (not to conform to DJI - just an error in cabling).

But the motor ordering seems find now.

When I go into terminal and do the SETUP > MOTORS command the order matches what I am expecting (front right, rear right, rear left, front left). Which of course is not 1,2,3,4 but they (by they I mean the programmers) are firing the motors in that specific order.

Ok, if you have checked both the ESCs calibration, motor rotation direction and propellers, recheck just in case :) then,

you may try the following procedures :

1 - Connect the APM to the mission planner, and having the quad in a flat and leveled surface, make sure the horizontal horizon is leveled, if not, run the "level apm" from the configuration tab.

2 - make a live calibration procedure rotating the quad in the 3 axis (also in the configuration tab)

3 - make sure you are using the quad firmware or that your frame is configured for quad in X or + configuration accordingly to your hardware configuration

 

4 - make sure you have erased/reset the board before and after uploading the firmware

 

5 - I'm not familiar with the dji ESCs, but if they have a brake setting, make sure it's off on all the ESCs

 

6 - Try to lower your RATE P to 0.080 and use te CH6 tunning feature to find your best RATE P setting. I think around 0.100 or 0.110 will be the best for your frame (I'm using one like that)

 

This is what I can think of right now, I hope there's a simple thing :)

 

I gatta tell you - the response time on these forums is fantastic.

At work now but I'll be back in the basement trying to figure this out tonight...

1. Did this already.

2. Hmmm... I did this before on this APM when it was going into a plane but not since I flashed it for copter. I'll try that tonight.

3. Yup. Did that.

4. Erased/reset? I didn't see an option for that so no - I didn't do this step. I'll go looking for it tonight (unless you get this reply and can tell me where that option is).

5.Good question - I dunno actually. This one may take a lot more research - I think I heard somewhere that these were not configurable though :-(

6. I'll try that tonight too!

in order to erase / reset, connect the board to the mission planner, go to "terminal" tab, and follow command line instructions to enter cli mode (tap RETURN 3 times if I'm correct), then, write "setup", you will be in "setup mode", write "erase" (this will wipe eeprom values), then write "reset" and anser "Y" (capital Y - this will assume default values for all parameters). Disconnect board from power and re connect it. This procedure should be done whenever you upload a new firmware, to clear the values from previous firmware.

You're a prince. I may have to rush home at lunch and try this all out!

No problem mate, just wish you can fly soon :), also, don't forget to calibrate your radio (also in configuration tab) and make sure you have it in "acro / plane" mode, without any mixing active. Sometimes there are folks using the same radio to fly a bunch of aircrafts and forget this.

I've reset it up from scratch.

Re-flashed the firmware.

Did an erase/reset from the CLI.

Setup my radio and did a motor test.

Change my stabilization P to .08 as someone suggested.

I've attached a video (forgot to show the computer screen saying that it was level so you'll have to trust me on that).

Kinda the same problem before - it wants to flip - although before it wanted to flip to the right, in the test I did after this video it wanted to flip back. Did the test again and it wanted to flip left... so it looks like the direction of flipping is random.

PLEASE someone help. I have a DJI/450/Naza as well but I'm really turned on by the APM capabilities if I can get it to work and I'll dump my other DJI.

http://www.youtube.com/watch?v=X5ys8eRj3YE

Hi... it's not the stab P wich you should change, but the rate P. Leave STAB P at 3.6 / 4 but lower the RATE P to 0.08 . If you can, please post your PIDs. A print screen will do it, just to check if there's any parameter with abnormal value.

First off... THANK YOU for all your assistance. I really appreciate it. I've attached some screen shots.

I'm kinda worried now that perhaps my mounding of the APM isn't as secure as it should be - I've noticed some drift. Too much give underneith - I push down on the board and it slowly going back to the quasi-original position. I'm going to go out to the hardware store (a block away) and pick up some supplies and fix that up in a jiffy.

In the mean time - I've attached two screen shots. I had adjusted the Rate Roll to .08, not the Stabilization control (all that is under the stabilization section so it was confusing to explain).

Ok.

I actually got it hovering for a few seconds.

I think the problem initially was that I did yesterday have two motors flipped wired wrong which caused it to always flip to the right.

I've been so cautious to try it now that I stopped it from flipping by cutting the throttle pretty quickly as soon as I saw two legs start rising more than 10 degrees before the other two started to rise.

This time I gave it more of a chance to get in the air - for the few seconds it was up (and only by 6 inches or so) it was incredibly twitchy... I immediately chopped the throttle.

The Naza I could fly indoors (within a reasonably tight space) for testing - there's no way I can do that with this beast at the moment - just way to twitchy/unstable.

So perhaps it's just a PID settings thing?


What do you think?

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service