[Resolved] No throttle control on arducopter 2.9.1, quadcopter 3DR, APM2.5

Update 19/02/2013: problem has been resolved. See discussions below for conclusion.

I am in a dead end that frustrates me to the point I might give up soon...any help welcome.
I have not yet flown my new quad that I try to finalize for weeks now,learning step by step how to solve the hidden road blocks. Except this time I am at a road block I can't resolve and do not find any info on the wiki.
This is the issue:
-I am at the stage where I have apparently succesfully calibrated the ESCs until step 6 of the wiki automatic calibration procedure
-After that if i turn on the quadcopter again and I arm it with the throttle stick bottom right for 4 seconds,then comes the issue:
Any throttle stick position make the four motors turn at a constant speed (except full down where motors stop). It is as if the throttle stick would be an on/off switch.
If i connect one esc directly to channel 3 of the receiver,then stick works as expected.
So is it a defect on my APM board,not able to send variable pulses to the output rail? is it a problem with 2.9.1?
(i was in stabilize mode)

Any advice/ help please!

Views: 10933

Replies to This Discussion

Thanks for the screenshots--I didn't know you could see the output values in mission planner like that.  That will definitely help me figure out if the bug I have is the same as you.


    What you're showing above looks pretty normal.  You know a quadcopter adjusts it's motor speed hundreds of times per second in order to keep balanced.  if you plot a graph of the motors they're constantly increasing decreasing in all kinds of patterns.  Checkout the images near the bottom of this wiki page to map the motor numbers to the physical locations.

    So for example when motors 2 and 4 are high it's the back motors that are providing more power probably because the copter is pitched back.

     Have you tried flying?  Could you provide a video of the copter itself when you try to fly it?

I've posted over on Jeremy's post as well but I suspect the issue is not with the APM but with the ESCs.  Some ESCs require a very low throttle position (pwm of below 1000) be sent to them before they will operate.

The issue may be that your transmitter provides a pwm value higher than this by default.  Could you check what your minimum throttle pwm is by looking in the mission planner's radio calibration screen?

What does not fit with this theory however is that you can make the motors turn by directly connecting to your receiver.  this is very strange because the APM should output the same min throttle as your transmitter as long as you've done the radio calibration recently.

Could you also try disconnecting all ESCs from your APM except that one that you have confirmed works when you connected it directly to your transmitter's channel 3 output?

A video of what you're seeing and a copy of your parameters file would also be extremely helpful.  You can save a copy of your parameters to a file from the mission planner's Configuration, Advanced Params, Adv Param List screen.

[copying my reply from the other thread here too]

This is quite odd.  I messed around with trim a bit and did radio recalibration with the min throttle at just below 1000 and then another time just above 1000.  No difference.

In the Mission Planner's status tab, I see the ch3in vary as I move the stick (armed or unarmed).  But the output channels never change.  It's as if APM doesn't believe I've disarmed yet, so it keeps things at the low throttle setting.

This sorta matches what I've seen before, which is that APM can spin the motors when I run the CLI motor test.  (And, yes, I've verified that I'm stabilize mode when I do my throttle testing).

This will not work for Opti ESCs, but it may work for others.

I had to calibrate my ESCs individually but still noticed erratic behavior.  Then I did a "throttle range setting" on the ESCs and the problems went away.  On my "Pentium" ESCs the procedure is:

1. No power on ESC or Tx.

2. Throttle up, switch on Tx, power up ESC - beep beep means high point confirmed.

3. Throttle down, number of beeps = number of cells, then a long beep indicating low point confirmed.

4. Power all down, cross fingers...

Hope this works for you.

Hello Randy,
My transmitter emits pwm 989 at lowest throttle. I will send you my param file but only next week feb 18th as i am away from my arducopter during this coming week...
I have same behaviour as what jeremy describes ch3 in is in line with throttle but output is kind of constant/erratic and certainly not in line with throttle input.

Also something important: at step 6 of the auto calibration procedure it works just fine ! It is after step 7 that it does not work anymore as it should. Step 7 consists in unplugging the lipo and reconnect it again,then trying to run the Motors.

How can we make a test to be sure APM motor ouputs provide the correct PWM ?
No i never tried to fly yet because i am not sure it is working. I understand you say it looks pretty normal but why can't i get a low throttle on the motors with a low stick? PWM out jumps immediately to high values instead of " copying" the minimum transmitter value of 989.
Would i dare try to fly this thing with no progressive thrust control?


     yes, I think you should buy some more props, motors and arms and be mentally prepared to break it and spend hours fixing it back up.

     ...then first try taking the props off and see how the motors react and make sure they're not going to full power as soon as you give it throttle.  You can also hold it in your hand (with props off of course) and try moving it around a bit and you'll be able to hear a bit the motor reacting. i.e. try leaning it on it's side...try rotating it horizontally, etc.

     ..then find a place where you're nice and safe (i usually hide behind a door the first time i try out a new copter) and where you're not going to damage anything too valuable and then give it a try.  Start with just short bursts of throttle until you're comfortable that it's under your control.

     ...at this stage keep it in stabilize mode at all times..don't try for alt-hold or anything yet.

If you want to see a pwm output that agrees with your input throttle you should average the four motor values instead of looking at the individually.  If you do that you'll see they generally line up.  The only difference is that the min throttle is 130 in order to keep the motors running.  Also the overall throttle is increased / decreased when the throttle is very low or very high to give better roll/pitch control.  Still, if you keep the roll-pitch sticks in the middle and keep the copter flat, you should see the average pwm output generally agrees with the input throttle.

Thx Randy, still another noob question: where do,i read the fournmotor PWM outputs ? In CLI ? how ?


    Sorry for the slow response...you can see them in the mission planner's Status tab at the bottom  of the Flight Data screen.


Hello Randy,

Thx a lot for your answer. I understand you have lots of other topics to read/answer so I understand also the delay. It is already a miracle you can follow all of this up ! (Ask Chris a pay raise ;)

Back to my problem. As you requested I made here below a video to explain and show what my issue is with throttle output from APM. The video proves the issue is with APM motors signals ouputs (ESCs are ok and are calibrated fine, ER9X Tx is fine also).

I also join in annex the log files I downloaded from the APM board while doing the tests in the video. I join you also my parameters file. (I left all parameters as defaults, except some of them like low_battery which have nothing to do with motor's control. The THR_min, max are on default values).

Maybe these side information are important to troubleshoot?:

-I have configured the failsafe on both battery and loss of Tx/Rx as per the wiki.

-I was also wondering if it could be a bad processing of the PPM by the APM ? My Tx is configured as "PPM 8CH 300µsec" (it is a turnigy ER9X firmware Tx).

Hope this will allow you to help me resolve my issue here. (as a last resort I will send back my APM board to 3D Robotics to have them test it, because I do not see any other explanation than a board/flight controller issue ?)




© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service