We use copter 3.5.5 for our hexa-rotors UAV.
The Vibration is in good level in stabilize mode. but changed worse in Loiter mode with forward flight.

The altitude control is getting worse.
Can anyone help?


the bin file is as follow:
https://drive.google.com/open?id=1C6132u1E64skSc9PigH2fo_lYiGeA2xO
https://drive.google.com/open?id=1Ib5Hd0XNB1VGVziVhc8i_GbKc2HofaWr

Views: 257

Replies to This Discussion

You have some nasty vibrations which are causing an IMU Mismatch:

Log File C:\Users\Cliff\AppData\Local\Temp\tmp91DA.tmp.log
Size (kb) 7007.5458984375
No of lines 86863
Duration 0:07:34
Vehicletype ArduCopter
Firmware Version V3.5.5
Firmware Hash 3441631b
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = NA -
Test: Balance/Twist = NA -
Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (21.77%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = GOOD -
Test: IMU Mismatch = FAIL - Check vibration or accelerometer calibration. (Mismatch: 2.10, WARN: 0.75, FAIL: 1.50)
Test: Parameters = GOOD -
Test: PM = NA -
Test: Pitch/Roll = NA -
Test: Thrust = NA -
Test: VCC = FAIL - VCC below minimum of 4.6v (0.0v)

Post pictures of your aircraft so we can see what is going on.  In particular show how the Pixhawk is mounted and how ALL of the external wires are routed.  

I also noticed there is not any battery data (voltage, current, total current) in the log.  This tells me that either you are not using a battery monitor, or you have it misconfigured.  Not having this data effectively renders the aircraft as being UNSAFE TO FLY for the simple fact that the low battery failsafe is not functional.  I also noticed that apparently Hover Throttle Learning is disabled and that the aircraft appears to be under powered.

Check the attached .jpg.  The red plot is Throttle Out.  The green line is the default Hover Throttle.  If hover throttle learning was enabled, the green plot would have converged with the red plot. 

The fact that your throttle out is above the default tells me the aircraft is hovering above 50% throttle (mid-stick) which is indicative of an aircraft that is under powered/over weight.

Attachments:

Hi Clifton,

Thank you for your help.

As you mentioned, the vibration level is extremely high, I noticed that if the vibe.clip was rising, the drone will suddenly climb up and lose altitude control. 

I tried to decrease the weight of IMU measurement, and let the autopilot trust Lidar and baro more through changing EK2 parameter, but failed.

Later we tried the vibration isolation, the vibration is getting worse, maybe the frequency is not suitable for this large hexa-rotors UAV which has 36 kg weight (16L payload)

Here is the pic of our UAV, the autopilot is directly installed on the central fuselage without any damping materials. we covered the autopilot with a box to avoid the static pressure changing. The external wires are arranged in C shape to avoid magnitude interference.

Thank you for your suggestions, we will enable the throttle leaning, BTW, in flight, the EKF IMU often change from 1 to 0, should I disable this function?  

Maybe we should try the inside vibration method? 

 Best wishes, 

David

The side arms are too long.  This non-standard configuration confuses the firmware and I'd wager this could be the source of the high vibration levels.

Hi Clifton,

 We will try to modify the mix file and have a flight test.

Clifton Hipsher said:

The side arms are too long.  This non-standard configuration confuses the firmware and I'd wager this could be the source of the high vibration levels.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service