Anyone managed to get pixhawk to control the t4-3d gimbal?

i've tried following the same steps in the wiki but that was for the 2 axis gimbal

http://copter.ardupilot.com/wiki/common-tarot-gimbal/

i cant get control the gimbal at all. It works when i plug the gimbal directly into a receiver like the conventional way. i've tried all different aux ports and tried different settings but just cant.

Anyone got this gimbal working with pixhawk before?

Views: 6187

Replies to This Discussion

I looked at that gimbal but it requires a Tarot FC as I recall. 

tarot t4-3d works with apm?

Hi There
I am looking into buying the T4 gimbal. Did you finally manage to make it work with the PixhawK?
I am currently flying a X8 with the pixhawk and occasionally with the tarot 2D
I was wondering if you succeeded to control pan and tilt.
Best

F

Hi,

Any update for the topic maybe?
I'm also interested about a solution.

yes there is a solution!!! make sure you have the latest firmware on your tarot t4-3d thats means v1.1

how to connect Tarot T4 gimbal to pixhawk: 

-set gimbal to pwm (not to sbus)

-connect pwm1 from gimbal to rc9(pixhawk) AUX

-connect pwm2 from gimbal to rc10(pixhawk) AUX

-go to mission planner -> intial setup -> optional hardware -> camera gimbal

        - set TILT to RC9 and do not check stabilization and then set what channel you want from radio RC6, RC7 ....

        - set PAN to RC10 and do not check stabilization and then set what channel do you want.

This worked for me, i have pixhawk and tarot T4. any question please ask :)

For anyone who is interested in connecting the Tarot T4-3D with the included Gimbal Main Controller Module to the Pixhawk PX4 on a quadcopter and failed you may want to read this...

NOTE: This method will enable Pan, Tilt and Mode via the S.BUS out of the PX4. The Pixhawk will not be "aware" there is a gimbal but in my application I don't care because I always use a remote to control my cameras.

I was having issues getting the PWM of the Tarot functioning. It made no difference if I plugged it in to the X8R receiver directly or the PX4, it simply wouldn't work with a PWM signal. I even tried the info in the post by B Petru in the thread and could not get PWM working. 

I discovered SBUS from the receiver would control the T4-3D  if I changed the T4-3D settings to enable SBUS instead of Conventional Receiver Type. This presented a new  challenge  though because my X8R is set to connect to the PX4 via SBUS  for channels 1-8 and I use the other channels on the X8R for camera switcher, LEDs,  lending gear and other basic functions on my heavily modified Matrice 100 frame (M100 a developer drone - I think not - another topic for another post but it is why I tossed the N1 flight controller in favor of the PX4).

So to how I got pan and tilt working:

  1. Make sure your Tarot is FW 1.10
  2. Use Mission Planner to install the latest firmware on your PX4.
  3. Set the channels on your remote to control pan, tilt and if you want, mode. In my case 6,7,8 for Pan, Tilt and Mode
  4.  Open Mission Planner do the following:
  • In Configuration select "Full Parameter Tree"
  • Find BRD_CAN_ENABLE and set the value to 1
  • Find BRD_SBUS_OUT and set the value to 1
  • Find RC6_FUNCTION, RC7_FUNCTION and optionally RC8_FUNCTION and set the value to 1
  • Write the parameters after editing

NOTE: Make sure you don't set, or if set already, disable any gimbal settings in Mission Planner, Initial Setup, >>Optional Hardare, Camera Gimbal.

NOTE: On some T4-3D gimbal units, the header with the 3 pins is pinned wrong. The yellow signal wire often needs swapped with the header with the single yellow wire. Look at the manual and make sure the yellow next to the video ground is connected to the header with the red and brown wire as this is what will connect to the SBUS output of the PX4.

This works flawlessly for me. I have the Taranis X9D Plus remote and I set the RS and LS pots to control Tilt and Pan and I set SC to control FPV/PF mode. The gimbal is very smooth and as far as I can tell it works as well as my old Zenmuse X3 gimbal.

You can find a PDF manual for the T4-3D at http://www.infinity-hobby.com/main/download/ZYX_T3D_Manual_EN.pdf

I do have a question for you if you don't mind.

Even though I am using SBUS, for future reference can you please define your gimbal settings in mission planner - especially the PWM variables and why type of gimbal? I am assuming you chose "servo".

I tried everything to get your method to work to no avail; I am about to run a second gimbal and would like the option because I like the Tarot.

Cheers,

Gio

Hey Guys, I also tried everything and can't get this thing to work.

I have a T4-3d on a Tarot 650, pixhawk flight controller, Taranis Plus and x8r receiver.  I ran a split off the sbus from the x8r directly to the gimbal (bound using D-16 to get a full 16 channels). Flashed the gimbal with V1.1 firmware.

The ZYX T3D software shows the commands from the transmitter to control tilt and pan, but the gimbal only briefly responds to tilt, then stops responding, but continues to hold level. 

Also tried B Petro's approach using PWM directly from the x8r and routed through the Pixhawk but can get no response on the ZYX T3D software or on the gimbal when using the PWM signals.

Thanks in advance,

Brad

Brad,

Am I understanding you are using a SBUS splitter? If so try SBUS without the splitter.

Did you follow the settings I described in Mission Planner? It is imperative you enable, SBUS passthrough on the channels controlling the gimbal and set the channels matching the transmitter mapping. With passthrough you don't set the settings for the gimbal; the remote passes the data on a specific channel and the Pixhawk is unaware there is a gimbal in this mode. I have not tested an SBUS splitter so I don't know if my method is compatable with that assuming that is what you mean (although it should be so long as there is no overlap)

I am of the opinion that  the Tarot does not respond to PWM and wish B Petru would respond to my question as to what variables he set to get PWM working.. I used a PWM sweep from my CNC router and didn't get any response - tried base frequencies from 5 to 5000 and nothing.  There is a 3rd option to control it via serial if I am not mistaken but I haven't explored that. I could be wrong though.

I guarantee that if the SBUS settings are correct it will work. I have 3 Tarot T4 units now and all on different frames and all work wonderfully. Also you do NEED the ground. It will not behave without it.

Just curious though - what buttons did you map to pan and tilt on your remote? The left and right POT style knobs on the side work well. You may also have to tweak the speed and torque settings. Mine are somewhere around 50 for torque on each axis. and 100 for speed

Let me know if I can be of more help.



Brad McMillan said:

Hey Guys, I also tried everything and can't get this thing to work.

I have a T4-3d on a Tarot 650, pixhawk flight controller, Taranis Plus and x8r receiver.  I ran a split off the sbus from the x8r directly to the gimbal (bound using D-16 to get a full 16 channels). Flashed the gimbal with V1.1 firmware.

The ZYX T3D software shows the commands from the transmitter to control tilt and pan, but the gimbal only briefly responds to tilt, then stops responding, but continues to hold level. 

Also tried B Petro's approach using PWM directly from the x8r and routed through the Pixhawk but can get no response on the ZYX T3D software or on the gimbal when using the PWM signals.

Thanks in advance,

Brad


Salut Gio, i'm at work right now, but when i'm going home  i'll look in mission planner to see exact settings for PWM.

And post it here the exact settings.

See you later.


Gio Michell said:

Brad,

I am of the opinion that  the Tarot does not respond to PWM and wish B Petru would respond to my question as to what variables he set to get PWM working.. I used a PWM sweep from my CNC router and didn't get any response - tried base frequencies from 5 to 5000 and nothing.  There is a 3rd option to control it via serial if I am not mistaken but I haven't explored that. I could be wrong though.

Grazie!

Like I said - SBUS works great for me but, like others on this thread, I can not get it to function via PWM.


B Petru said:


Salut Gio, i'm at work right now, but when i'm going home  i'll look in mission planner to see exact settings for PWM.

And post it here the exact settings.

See you later.


Gio Michell said:

Brad,

I am of the opinion that  the Tarot does not respond to PWM and wish B Petru would respond to my question as to what variables he set to get PWM working.. I used a PWM sweep from my CNC router and didn't get any response - tried base frequencies from 5 to 5000 and nothing.  There is a 3rd option to control it via serial if I am not mistaken but I haven't explored that. I could be wrong though.

Hey Gio thanks for your reply. We are currently connecting the gimbal via an sbus splitter from the receiver to the Pixhawk, and have the pan and tilt mapped to the left and right pot sliders. I can see the sliders on the Tarot gimbal software moving when I move the pot switches, but the gimbal does nothing.  I'll try your suggestion of connecting without a splitter. Are you connecting the gimbal directly to the Pixhawk Sbus port?

I configured the settings like you described above, however I cannot find BRD_CAN_ENABLE parameter. I found both BRD_SBUS_OUT and the RC_FUNCTION and set those according to what you've described, but could not find the other one. I'm using the latest Mission Planner with the latest firmware on the Pixhawk. Could it be called something else? What version of Mission Planner and Pixhawk firmware are you using? I also made sure the MP gimbal settings were disabled. 

Thanks again!

Brad

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service