Does anyone know wtf is up with this 'uBlox 6M GPS Module V2' that i just got from RTFquads? I just set this board up and i am trying to get this all going but for some reason it isn't being seen by the APM. I tried to upload the GPS passthru to the APM following Randy's youtube video but i couldn't get that to see it either?

Anyone know what these sequence of light are?

Really want to get this quad in the air asap but this seems to be what is stopping me. When i connect all i get is 'NO GPS'....

Any help is totally appreciated. THANKS!!

this is the gps:

Views: 2665

Replies to This Discussion

thanks randy, et al.

going to try this.


I am not too familiar with the Arduino IDE but I did a git clone and went went to that file in the Arduino IDE and tried to compile that file:

and at the bottom i got:

GPS_UBLOX_passthrough.pde:10:23: fatal error: AP_Common.h: No such file or directory compilation terminated.

Any help is totally appreciated!

Thanks all!

Make absolutely sure that your cable connections are correct. Then try to use Ucenter to set the configuration back to defaults. If that is successful load the 3DR script. Brought mine back to life.

Second that. And after you think it's configured correctly, double check by refreshing. I found mine did not take the first couple of times.

Hey Randy,

I tried to compile it a few times doing different things to try to get it compiling correctly, eg putting in libraries into the sketchfolder....

Unfortunately i got nowhere. Is there anyone who can successfully compile this sketch and upload the hex here? I am pretty sure if you know what you are doing this would prolly take 30 seconds, yeah?

Thanks in i am feeling really frustrated like just giving up here.


Do you have an FTDI cable? If you do use it with UCenter which you can find on-line from U-Blox. UCenter has a lot of tools and you will quickly know if your GPS is working. However there can be some issues with different FTDI Cables. You can download the 3DR firmware that Mark mentioned above which will set up the correct baud.

Also you can look at your log files it will show if you are getting any response from the GPS.

If you don't have a FTDI cable I would invest in one. They are cheap and very handy to have.

@Rob Dunbar

I have one but i have move to Portland, OR and everything i have including that FTDI cable is in storage. So i am trying to make do with what i have here and everything is almost there (i think).... just this GPS is the problem.



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service