I'm trying to get my RTF Y6 off the ground for the first time. 

I calibrated the ESCs, checked motor spin, ran the calibration wizard in MP (Turns out I had to run a virtual machine on my Mac to use MP, because APM Planner wouldn't work on it for some reason; this cost me a couple weeks of troubleshooting). Everything looks good. 

I arm the PX4, arm with transmitter, transmitter in stabilize mode, props spin (in the correct directions, with writing facing toward the sky, on both top and bottom propellers). Throttle is responsive, pitch and roll are responsive. 

But, the copter won't leave the ground, even with throttle maxed out. It's like it just doesn't have enough power to fly. 

Any suggestions? 

Views: 1317

Replies to This Discussion

Hi Ben,

Have you calibrated your 'Throttle' under the Initial Setup/ Radio configuration in MP?

Which version of ArduCopter are you using?

Regards,

Shyam

Keeping an eye on this!  At the DC Area Drone User Group monthly fly in on Saturday, we had someone with a new 3DR Y6 having the EXACT same problem.  He's a newbie with it, so several of us were trying to help him troubleshoot.  Radio calibrated and tracking correctly.  ESCs calibrated.  When doing the ESC calibration, the motors all spun up to full power.  But as soon as you let the APM try to run the motors, they would hardly spin up to a little over idle.

I know you've checked everything but your props must exactly reversed.  Swap the front props left-right and then the rear props left-right and it should liftoff with no problems.

Things to double-check:

1) Done throttle calibration in the setup wizard

2) Using 3s or 4s batteries

3) Check prop orientation/direction again!

4) Do that ESC calibration again

The symptoms we experienced were definitely not related to the props being backwards.  It's pretty obvious by looks and sound when the motors at a measly 20% power vs full power and just spinning backwards.  We did the radio calibration and the ESC calibration twice.  Did the motor test to confirm direction.  Quadruple checked everything.  It's like the Pix is not passing more than 15-20% power to the speed controllers.  This sounds like what Ben is experiencing too.

Hi Chris, thank you very much for the suggestions!

I went through those four steps again, with the following results:

1) Recalibrated the radio, all good.

2) The battery is the Tiger 6000 mAh 35C that came with it, pretty sure it's a 3S.

3) Double-, triple-checked prop orientation and direction. Top motors spin clockwise, bottom motors spin CCW. Writing facing the sky.

4) It got interesting when I then did the ESC calibration again, because I could hear what the motors are capable of at full throttle. The POWER! Rad.

When I armed the motors again and spun it up like I was flying it (props off, inside my house), it was still only getting like 20% power with full throttle, however.

I'm not sure what else to try at this point!  

Ding ding. Same exact thing we did at the fly-in on Saturday. Damned if any of us could figure it out. Also, the pitch, roll, and yaw does respond.  If you move the sticks, the motors will change RPM accordingly.

The only think we didn't do is dig though all the parameters.  Is there a parameter that would limit motor output like this?

Are you sure you've loaded the right configuration file? The old Y6 config had a mix of CW and CCW. The new one is as you describe with all one direction on top and the other direction at bottom. 

If you ordered a RTF with radio all of this will have been set up at the factory and there is no need to set it up at all -- it will fly right out of the box. If you're using your own radio, you do indeed need to go through the config process and select the right model type.

What radio are you using? And are you sure it's in airplane mode (good) and not heli mode (bad!)?

Yes, exactly the same. 

The ESC calibration (done after calibrating the RC) shows that the motors are capable of much, much more. So it's not a battery issue. It's like there's a limiter on the PX4, not letting full power to the motors. 

I'm using the DX7S that came with it, Y6B firmware, airplane mode. 

If so, you should not have had to do the configuration process at all - it was set up at the factory. It sounds like you may have overwritten the factory settings. It's probably best for you to work with tech support directly at this point.

I agree with Chris that it's most likely that the factory config has been overwritten or that the propellers have been put on the wrong way.  It sounds silly but it happens.

You can check the motor order with the CLI's "test", "motor" command.  It's documented on the wiki here.  If all the motors spin in the correct order and the correct direction then next it would be best to carefully look at the propellers and make sure they're spinning the right way.

Posting a close up video of the copter while it's running the motor test will probably let us see what the issue is.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service