I use the APMRover with Pixhawk ,GPS and a skid steering rover .It's perform very well in Manual Mode.But when I switch to Auto Mode it switch to RTL Mode automaticlly.It still can switch to Manual Mode ,Hold and Learning Mode at any time.Neither RC nor 3DR Tower is work.In addition,Guide Mode is Work and all failsafes set to Hold.


Thanks!!!

Views: 479

Replies to This Discussion

@wikeex,

Please provide a copy of your Full Parameter File in a text file.

What receiver are you using on your rover?

Regards,

TCIII AVD

I use a normal receiver with PPM encoder.

Attachments:

Actually,I use APMRover on a dual motor boat.I think it can work like a skid steering rover.When I had uploaded the mission first time it worked.Then I switched to Manual and I haven't able to return to Auto since.Except Auto becomes RTL ,other modes are effectual.

Could you provide a copy of your dataflash log file when you go into auto and the vehicle RTLs?

Thanks, Grant.

Thanks a lot !! My log file is too large to upload. I intercept a section of it. I will send an e-mail to you if you need.

Attachments:

Make sure you Restart the mission each time you run it.

Your mission is unusual.  Your second mission item is a takeoff command.  Your in a rover right?  Then you have a bunch of spline waypoints which rover will also ignore followed by an RTL command.  I suspect Rover is ignoring all the other waypoints and the first thing its doing is an RTL as its the first one it understands.

I have attached your mission so you can confirm.

Thanks, Grant.

Attachments:

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service