Hey ,

 I am trying to control my Rover with a Companion Computer ( Raspberry Pi). I have installed DroneKit Python on the Pi, The commands works fine for a Copter as most of the tutorial says. but they do not work for Rover. 

The Raspberry Pi is getting connected to the Pixhawk, but when the pi commands the Pixhawk to move with vehicle.message_factory.set_position_target_local_ned_encode the Rover dose not move. this worked fine for the QuadCopter. 

Is there any alternative or any other way by which i can control the Rover any help is appreciated.


Views: 2016

Replies to This Discussion

I always change the mode to guided first and then use simple_goto()

Simple Goto is working for the SITL only But not for the Actual Rover.. 

Cruise Speed is set at 2 m/s and 

Throttle is at 20 % can you say what can be the issue. 

You armed the Rover and put it into guided mode before using simple_goto? My rc car needs more than 20% throttle to start moving. Once it is going I can back it off. Maybe try increasing throttle a bit.

Akshay it should work - have you resolved the issue?

Thanks, Grant.

Like Akshay, I am coming from the Copter side.  I have my rover setup with an onboard Odroid XU4 and Dronekit-Python.  When I run a simple script to do a single simple_goto, the rover takes off much faster than it should.  In the script I set the dronekit groundspeed parameter: self.vehicle.groundspeed = 0.5   I'd guesstimate that the rover is moving more like 2 m/s.  How can I control the speed?  Thanks.

You might need to set the throttle slew rate lower in rover for the taking off issue.  Also there is the cruise throttle, you could set it in rover first then use the same cruise speed in your scripts.

Thank you, Ray.  I have the cruise speed set at 0.5 m/s (I want it to move slowly during initial testing) and I think the cruise throttle set to 50%.  Is that a reasonable value?  I haven't touched the slew rate -- it is still at the default.  I'll lower it.

Cruise speed is fine, throttle may be too high.  Cruise throttle is the initial throttle guess, so it will start at 50% then after it figures out how fast its going it will correct.  With slew at 100 that means it will punch 50% from a stop, that may be too fast.  Set your cruise throttle to match either your APM desired speed or companion desired speed, and I have my slew rate way down so it accelerates slowly.  My rover is meant for use across rough terrain though and uses NiMh, if you are on LiPo and smooth ground you might just need to set the throttle.

That's very helpful, I'll give it a try.  Thank you.

Sure thing, let me know how it turns out.

Hey guys thanks for your replies .... i am sorry for my long absence, 

I needed the throttle to be around 40% for the car to start moving . 

as David Mathias  i also faced the same problem of over speed , 

Lowering the throttle slew rate as  Ray Quintana suggested should do the trick. 

The speed issue is solved. The problem I'm having now is with weaving. I'm using a uBlox mounted on a mast and have the internal compass disabled. I've checked for magnetic interference from the motor - it doesn't appear to be a problem. I've looked at some other threads on this problem and checked the suggestions. The only thing that stands out is that I'm currently testing at very low speed -- 0.5 m/s. Any thoughts? Thanks.


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service