I'm a technology instructor at a new Applied Tech HS setting up a long term rover project and working out the kinks over the summer. I will ultimately be using the Dagu wild thumper and a sabretooth dual brushed esc. for our projects. 

For now, due to time constraints, I picked up a Dagu Rover 5 and a t rex dual motor controller. I've had success setting the rover 5 up as a straight up RC vehicle using a spektrum dx4c rc car controller and receiver.

Given that success, I now want to introduce the 3DR Pixhawk auto pilot and having a difficult time getting it to work. 

Mission planner reads channel inputs but the T Rex isn't seeing the signals and thus no outputs. The T Rex blinks rapidly green. I was able to calibrate channels in the trex calibrate mode but once I reboot with jumper off it isn't responding.

Regardless of where i place outputs on the pixhawk the only channels I get response on are pitch and roll - I've got the mixing jumper in place and wonder if there is an issue there as Pixhawk would do the mixing? Regardless with or without the mixing jumper, I'm not getting any signal to the trex.

I assume the trex should remain in rc mode? or would this be an analog input?
I'm using a Spektrum system (PWM) and the PPM converter sold by 3DR.
Not clear which channels on the PPM converter correlate to the necessary channels for driving the rover with a surface controller. If easier I can change to a 6 channel air system and use right stick.
Also a bit unclear what servo wires I need from T rex to pixhawk aside from 1 and 2 as it would seem that pixhawk is taking over for sending signals for mode, etc. 

I have a lot of experience with the Pixhawk on multicopters but a bit confused with the rover clearly.

Any help greatly appreciated


Views: 1401

Replies to This Discussion

Hi Steven.  Did you press the safety button on the pixhawk so it stopped flashing?  No outputs will be sent until the safety button has been pressed.

I've never used a T Rex dual motor controller.  I skimmed the data page.  Yes, it should remain in RC mode which means PWM.  If you set it to analog it means it would drive the output based on input voltage level but we don't do that.  Its PWM the pixhawk outputs so RC mode.

I've never used a Spektrum system either but I know people are using it just fine so you should be ok. 

I don't know what you mean when you say "surface controller".

I don't know what you mean when you say you can change to a 6 channel air system either.

I think you only need to connect 1 and 2 to drive the motors.

Best if you can do some diagnostics.  If you have a look at this video it will show you how to graph real time values

https://www.youtube.com/watch?v=w4G4K5Q27hw

If you graph ch#in and move the sticks you will be able to see if the pixhawk is seeing the inputs coming from your transmitter.  You could then do the same with ch#out and see if the pixhawk thinks its outputting something.

Another option is to plug a different ESC onto the pixhawk with a different motor if you have it (use one off your mutlirotor) just to test if its getting output.

Let us know how you go.

Thanks, Grant.

Hey Grant,

Thanks so much for your detailed response.

I'm referring to using an aircraft rc controller - in this case a dx6i spektrum with a 6 channel dsmx air receiver for manual control.

The alternative would be a dx4c controller that is used for model cars - it has a throttle trigger and steering wheel type steering input.

In reading the APM rover wiki, it states it is meant for aircraft type controllers using the right centerloaded stick normally used for pitch and roll in mode 2 setup.

I've gone ahead done all that and also ran diagnostic as directed in youtube video - both channel 1 and 3 show proper input and output. I was sure to press the arm switch though in the graph it doesn't seem to make a difference - only when I want to operate the vehicle manually does the safety switch need to be solid red.

I wonder if it is something to do with the trex controller as when I do a learning mode calibration for it to learn the ranges, it only shows me one green blink meaning it has only learned the limits of one channel.

This doesn't make sense to me as it should be seeing two channels. I guess it could still operate both tracks but not know the limits of one side of the rover. To explain further - as in the thumper - I have ganged the front and rear motors on the left to operate as one and done the same on the right.

I have skid steering attributed as skid steer IN 1, skid steer OUT 0 as that seems to be the setup for an rc controller operating with one stick.

I tried changing rc cable between pixhawk and trex on offending channel not calibrating but no change. Also tried shifting to pixhawk out put 1 and 3 but no difference whether 1 and 3 or 1 and 2.

When the board is armed it will slowly spin clockwise only rotating the right motor.

Thanks for any further advice/input. Very much appreciated

@Steve,

When you attached the PPM Encoder to the R/C receiver did you follow this connection scheme:

PPM Encoder 1 to receiver Aileron channel

PPM Encoder 2 to receiver Elevator channel

PPM Encoder 3 to receiver Throttle channel

PPM Encoder 4 to receiver Rudder channel

PPM Encoder 5 to receiver Gear channel

PPM Encoder 6 to receiver Aux channel

If you decide to use a Spektrum Remote receiver instead of a PPM encoder, then you need to change the RCMAP to the following:

RCMAP_PITCH 3

RCMAP_ROLL 1

RCMAP_THROTTLE 2

RCMAP_YAW 4

You really need a R/C transmitter with seven channels like the DX7 so that the Flap switch has three positions so you can select Manual, Learning, and Auto modes with one switch. The Gear switch is used to record waypoints.

What channel do you have the LEARN_CH set to? It should be 5.

What channel do you have the MODE_CH set to? It should be 6.

If you did not, then that may explain why your rover is not working correctly.

Your right and left channel inputs to the TRex should therefore come from the Pixhawk servo outputs 1 and 2. You will have to experiment as to which Pixhawk output is for the right channel and the left channel.

Regards,

TCIII AVD

thanks for your help Thomas,

I was able to get it working manually via pixhawk today with the connections as follows:

PPM Encoder 3 to Aileron

PPM Encoder 1 to Elevator

PPM Encoder 8 to Gear

PPM Encoder 7 to Aux

Mode channel in mission planner is 8. 

I'll give this a try and let you know how it goes. It just spins in a circle when I load a mission and engage auto mode.

@Steven,

Check the "reverse" box next to the Roll (Aileron) bar in the Radio Calibration screen to correct your issue in the Auto Mode.

Regards,

TCIII AVD

thanks for that tip Thomas!

I've done a lot of mission planning for air vehicles. Does the rover require a "take off" command in the script or will throttle initiate?

Seriously can't thank you enough for the rapid response!

Steven,

When you go into the Auto Mode the navigation controller will apply throttle up to the CRUISE_THROTTLE value (%) you have set to reach the CRUISE_SPEED (m/s) that you have set.. You can use the THR_SLEWRATE parameter to set the rate at which the throttle is ramped towards the CRUISE_THROTTLE value.

ArduRover2 full parameter values are here Link

Regards,

Tom C AVD

thanks once again.

Compass variance error seems to be causing auto mode to behave oddly - compass is spinning slowly though I have calibrated several times. I've also tried manual declination setting without luck.

googled it but not certain what is causing it to make wide lazy circles!

Compass variance error persists.

I've tried placing a copper shield underneath the pixhawk and elevating the gps/compass to no avail.

I've swapped gps/compass module and tried another i2c cable for the compass and same result. 

I originally thought it was only occurring when powered by a lipo and not when connected via USB but that is actually not the case.

Are there actually 2 compasses used with the Pixhawk and 3dr GPS unit? It seems that when my vehicle turns the compass reacts but when the gps module turns it doesn't. 

After further noodling, it seems that sometimes the compass works and other times not so much!

I had it tracking an autonomous route that seemed to weave a bit, at times losing its way and circling. 

Also tried increasing speed but still crawls. I had 2 m/s speed and increased throttle % to 50% as a start point and then increased to 10 m/s with no change in actual speed or ramp to speed.

scratching head vigorously...

@Steven,

"Also tried increasing speed but still crawls. I had 2 m/s speed and increased throttle % to 50% as a start point and then increased to 10 m/s with no change in actual speed or ramp to speed."

The Wild Thumper can be purchased with brushed motors of varying ratios: 34:1 and 75:1.

If you purchased the 75:1 model, it is not going to be going real fast. The 34:1 model is going to be faster.

I doubt that you are going to be getting 10m/s (22mph) out of either gear ratio chassis.

My Traxxas brushless 4WD Slash can easily do 10m/s, but not a Wild Thumper.

Regards,

TCIII AVD 

this is the dagu robot 5 for the moment and I'm not really looking for speed just indicating that the change in speed setting had no effect. It goes much faster in Manual mode though that is not particularly snappy.

Really my main source of consternation is the compass errors and it going in lazy circles at random times.

There is an internal compass on the Pixhawk itself and an external compass in the 3DR GPS/Compass module.  When ardupilot starts it automatically detects if the external compass is available and uses it if it is.  Otherwise it will use the internal compass.  If the Pixhawk is going to use the external compass it automatically sets COMPASS_EXTERNAL to 1 to indicate this.  You should not manually set COMPASS_EXTERNAL if you are using a Pixhawk.

http://rover.ardupilot.com/wiki/apmrover2-parameters/#compass_is_at...

Thanks, Grant.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service