I am having difficulty connecting a pixhawk to a sabertooth motor controller. I am going from the SBUS on a FrSky X8R receiver to the RC in on the pixhawk. then from channels 1 and 3 to the sabertooth motor controllers signal 1 and 2. The sabertooth is configured for skid steer. In the radio config page of mission planner, I am able to calibrate all the channels, but the motor controller only responses to forward and reverse, no steering. I have included a picture of the test setup below, dipswitch positions, mixer and input settings on Taranis, and mission planner skid steer settings. Any help you can give me would be greatly appreciated. Thank you

Pixhawk channels 1 and 3 to sabertooth controller. Signal, Power, and Ground wires on each cable

System powered on

Dipswitch for Skidsteer

Taranis Inputs

Taranis Mixer

Skid Steer Mission Planner

Views: 2063

Replies to This Discussion

@Jake,

Why do you have SKID_STEER_IN and SKID_STEER_OUT disabled?

SKID_STEER_IN should be 0 and SKID_STEER_OUT should be 1

You should not be doing any mixing of the roll and pitch channels in the transmitter.

Please show your four RCMAP parameters for the Pixhawk: RCMAP_ROLL, PITCH, THROTTLE, YAW

You might try connecting the Sabertooth inputs to Pixhawk channels 1 & 2 instead of 2 & 3.

Regards,

TCIII AVD

It looks like you are using the Sabretooth drive to accept a throttle and a steering signal.

The drive by default will try to auto calibrate to the r/c signal each time it is powered on. Also there is a time-out feature if there is no signal.

Your dip switch settings are correct, but you will have to use the DeScribe setup software to change it to accept a fixed range of PWM signals.

Check out page 14 of the manual.   HERE     There is a check box on the RC tab that will force it to use the fixed PWM range.

I don't know if that defeats the loss of signal time-out feature or not.

Chris

@Chris,

I have never had to reprogram a Sabertooth motor controller, as you have described, to get it to work with the Pixhawk's servo outputs.

However, the Pixhawk will not output a PWM signal on its servo outputs until it is armed. Therefore I always arm the Pixhawk before I apply power to the Sabertooth motor controller in order for it to see a PWM signal on its two inputs.

Regards,

TCIII AVD

@Jake,

Try swapping the Pixhawk output channels 1 & 2 to the Sabertooth motor controller.

Take a look at this thread on ArduPilot.com concerning a similar problem to yours and the eventual solution.

Regards,

TCIII AVD

@Thomas,

I haven't used a Sabertooth with APM or Pixhawk, I've actually only used the 2x60's, with potentiometers or with the kangaroo feedback controller to make big R/C controlled servo motors.

Your experience in these matters trumps my suggestions.

Chris

@Jake,

Did you try swapping the PITCH and THROTTLE parameter numbers in the RCMAP?

Regards,

TCIII AVD

@ Thomas.

For the sake of curiosity...

I guess that using a Sabertooth dual output motor driver for skid steer that there are conceivably three different ways to accomplish the skid steer control setup.

1.  [Skid steer output]  Use normal aircraft or RC-car TX with throttle for speed command & aileron/rudder or steering wheel (Car TX) for steering and let the Pixhawk controller perform the mixing and the Sabertooth drives the two motors from independent signals provided by the Pixhawk.

2.  [No skid steering selected]  Use normal aircraft or RC-car TX with throttle CH for speed command & aileron/rudder or steering wheel (Car TX) for steering and allow the control signals pass-through the Pixhawk without mixing and have the Sabertooth perform the skid steering mixing functions.

3.  [Skid steer input]  Use a TX with the differential mixing done on the TX and the Sabertooth drives the two motors from independent signals provided by the Pixhawk.

i guess that the first one would be the more straight forward choice as all the mixing control and the servo trims etc. are setup in one place [ so to speak ] , where as the other two involve mixing on another device, be it before or after the Pixhawk.

Does what I wrote 'square-up' correctly? ...gramer notwithstanding...

Chris

@Chris,

And the correct choice is #1 if you are going to go to the expense of buying a Pixhawk in the first place.

Regards,

TCIII AVD

@Jake,

I have alerted our ArduRover firmware Developer, Grant Morphett, to your issue and hopefully he can reply soon.

Regards,

TCIII AVD

@Jake,

Try checking the reverse box next to the roll (steering) channel on the MP radio calibration page.

Regards,

TCIII AVD

Hi.  As I understand it you have the throttle on the throttle stick but you want it on the elevator stick presumably so it self centres and your rover stops.  This is certainly how I have it.

If your throttle stick is already moving the rover correctly and you just want a different stick on the transmitter to do the same thing the easiest thing to do is make the change on your transmitter.  Your throttle will be outputting on a certain channel (I would guess 3) so simply move that output channel to your elevator stick.  Does that sound ok or have I mis-understood something?

Thanks, Grant.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service