Every time I configure the compass successfully, I get the message "PreArm: Compass Offsets too high". The most recent values are X:-144, Y:-261, Z: 586. This seems to be causing an issue with the Motors. After dozens of tries of either "sudo ~/ardupilot/libraries/AP_HAL/examples/RCOutput/RCOutput.elf" or Ardupilot motor test/calibration have only succeeded twice. These problems seem to be interconnected in that in both cases I cannot get the motors to turn on.

There are at least a half dozen of us doing BBBMini builds in our local group, and so far no one has gotten past this point yet (although only a few of us are at the RCOutput test).

Any suggestions?

Views: 1124

Replies to This Discussion

Hi Justin,

can you post a picture of your setup please.

Regarding RCOutput.elf, this file can not be used to test / calibrate the motors / escs.

Regards

Mirko

Mirko,

Using Turnigy 9x with Arduino.

RCInput works, as does Sonar, Barometer, and Inertial Sensor. GPS is not yet connected.

Motors and electrical connectors have been tested successfully separately.

Justin


Mirko Denecke said:

Hi Justin,

can you post a picture of your setup please.

Regarding RCOutput.elf, this file can not be used to test / calibrate the motors / escs.

Regards

Mirko



Justin C said:

Mirko,

Using Turnigy 9x with Arduino.

RCInput works, as does Sonar, Barometer, and Inertial Sensor. GPS is not yet connected.

Motors and electrical connectors have been tested successfully separately.

Justin

Mirko,

As an aside, most of my tests have been with Mission Planner's Motor Calibration. However, there were a couple of times that the motor's did cycle successfully using RCOutput.elf, although after trying to do the calibration with Mission Planner, I understand why that type of testing is unreliable.

The main issue is that there is the "Compass Offsets too high" issue that is preventing the arming.

Justin


Mirko Denecke said:

Hi Justin,

can you post a picture of your setup please.

Regarding RCOutput.elf, this file can not be used to test / calibrate the motors / escs.

Regards

Mirko

Hi Justin,

I have the same problem, mainly when using external compass, I'm using a secondary IMU too, the external compass ( I tried to use roll 180 as APM2, or 5volts powered with level converters) but external compass, no way. 

Go to http://discuss.ardupilot.org there's some talk about compass calibration inconsistencies

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service