Tarot 2 Axis Initialization Problem

I installed a Tarot gimbal on my Tarot Fy680 Pro hexcopter and it has worked fine. One day, I took off to fly a waypoint mission and switched to Auto mode just after takeoff - the motors throttled back for some reason and the copter settled down before I could take over manually. The copter bounced when it hit the ground (the landing skids are nylon rods, which flexed kinda like a diving board), and the copter tipped over on its nose.

There was no physical damage other than a bullet connector came apart. But the gimbal didn't work after that. I ordered a new gimbal gyro control board and installed it - when I powered up the gimbal, the motors responded and it appeared to work fine. Later, I adjusted the tilt limits. But the next day, when I took it out to the field to fly, the gimbal motors failed to respond.

When I power up the gimbal, I see a green led followed by a yellow led that glows solid for a few second, flashes once and goes out and a blue led comes on and is solid. It appears to have completed it's initialization, but the motors do not move - the camera remains tilted.

I'm drawing power from the balance plug, picking off 11 volts even though I'm using a 4S lipo. in addition to the gimbal, I'm also powering a 600 mW video transmitter, which works fine.

I'm loathe to but another gimbal control board until I can figure out what went wrong. I'm tempted to replace the whole unit, but that's another $100... 

Does anyone have any ideas?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • After you replaced the board, did you calibrate the gimbal? If you haven't please do it.

    • Yes, I did the calibration. And when I tried to start the motors via the GUI, the gimbal motors did not respond.

This reply was deleted.